summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-11 12:23:19 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-11 12:53:18 +0100
commit3ee411f1324ad2b881555d1bec5f943f1a7f28a1 (patch)
tree6f41e60778fca61521342418fc05d60e95f9ae44 /dev-python/clang-python/clang-python-19.1.4.ebuild
parentRename {sys-devel → llvm-core}/clang-common (diff)
downloadgentoo-3ee411f1324ad2b881555d1bec5f943f1a7f28a1.tar.gz
gentoo-3ee411f1324ad2b881555d1bec5f943f1a7f28a1.tar.bz2
gentoo-3ee411f1324ad2b881555d1bec5f943f1a7f28a1.zip
Move {sys-devel → llvm-core}/clang
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/clang-python/clang-python-19.1.4.ebuild')
-rw-r--r--dev-python/clang-python/clang-python-19.1.4.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-python/clang-python/clang-python-19.1.4.ebuild b/dev-python/clang-python/clang-python-19.1.4.ebuild
index ea8472ba126c..72e33b7dc260 100644
--- a/dev-python/clang-python/clang-python-19.1.4.ebuild
+++ b/dev-python/clang-python/clang-python-19.1.4.ebuild
@@ -6,7 +6,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..13} )
inherit llvm.org python-r1
-DESCRIPTION="Python bindings for sys-devel/clang"
+DESCRIPTION="Python bindings for llvm-core/clang"
HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
@@ -19,9 +19,9 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
# The module is opening libclang.so directly, and doing some blasphemy
# on top of it.
DEPEND="
- >=sys-devel/clang-${PV}:*
+ >=llvm-core/clang-${PV}:*
!sys-devel/llvm:0[clang(-),python(-)]
- !sys-devel/clang:0[python(-)]
+ !llvm-core/clang:0[python(-)]
"
RDEPEND="
${DEPEND}
@@ -30,7 +30,7 @@ RDEPEND="
BDEPEND="
${PYTHON_DEPS}
test? (
- sys-devel/clang:${LLVM_MAJOR}
+ llvm-core/clang:${LLVM_MAJOR}
)
"