summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-21 08:38:15 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-21 08:39:03 +0200
commit3e36c5ac0f1d18a53cba39ea36c3279bee994f37 (patch)
treeb78a90a68046393978585e1a26adbac2255930d3 /dev-python/clang-python
parentmedia-libs/openal: Stabilize 1.22.2-r1 ppc, #872128 (diff)
downloadgentoo-3e36c5ac0f1d18a53cba39ea36c3279bee994f37.tar.gz
gentoo-3e36c5ac0f1d18a53cba39ea36c3279bee994f37.tar.bz2
gentoo-3e36c5ac0f1d18a53cba39ea36c3279bee994f37.zip
dev-python/clang-python: Run tests against matching clang library
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/clang-python')
-rw-r--r--dev-python/clang-python/clang-python-15.0.1.9999.ebuild6
-rw-r--r--dev-python/clang-python/clang-python-15.0.1.ebuild6
-rw-r--r--dev-python/clang-python/clang-python-16.0.0.9999.ebuild6
-rw-r--r--dev-python/clang-python/clang-python-16.0.0_pre20220918.ebuild6
4 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/clang-python/clang-python-15.0.1.9999.ebuild b/dev-python/clang-python/clang-python-15.0.1.9999.ebuild
index 2891edc42793..f0290ca4c7b1 100644
--- a/dev-python/clang-python/clang-python-15.0.1.9999.ebuild
+++ b/dev-python/clang-python/clang-python-15.0.1.9999.ebuild
@@ -29,12 +29,18 @@ RDEPEND="
"
BDEPEND="
${PYTHON_DEPS}
+ test? (
+ sys-devel/clang:${PV%%.*}
+ )
"
LLVM_COMPONENTS=( clang/bindings/python )
llvm.org_set_globals
python_test() {
+ # tests rely on results from a specific clang version, so override
+ # the search path
+ local -x CLANG_LIBRARY_PATH=${BROOT}/usr/lib/llvm/${PV%%.*}/$(get_libdir)
"${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
}
diff --git a/dev-python/clang-python/clang-python-15.0.1.ebuild b/dev-python/clang-python/clang-python-15.0.1.ebuild
index 3e0bc84f48a0..ebf4d5ceb506 100644
--- a/dev-python/clang-python/clang-python-15.0.1.ebuild
+++ b/dev-python/clang-python/clang-python-15.0.1.ebuild
@@ -29,12 +29,18 @@ RDEPEND="
"
BDEPEND="
${PYTHON_DEPS}
+ test? (
+ sys-devel/clang:${PV%%.*}
+ )
"
LLVM_COMPONENTS=( clang/bindings/python )
llvm.org_set_globals
python_test() {
+ # tests rely on results from a specific clang version, so override
+ # the search path
+ local -x CLANG_LIBRARY_PATH=${BROOT}/usr/lib/llvm/${PV%%.*}/$(get_libdir)
"${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
}
diff --git a/dev-python/clang-python/clang-python-16.0.0.9999.ebuild b/dev-python/clang-python/clang-python-16.0.0.9999.ebuild
index 2891edc42793..f0290ca4c7b1 100644
--- a/dev-python/clang-python/clang-python-16.0.0.9999.ebuild
+++ b/dev-python/clang-python/clang-python-16.0.0.9999.ebuild
@@ -29,12 +29,18 @@ RDEPEND="
"
BDEPEND="
${PYTHON_DEPS}
+ test? (
+ sys-devel/clang:${PV%%.*}
+ )
"
LLVM_COMPONENTS=( clang/bindings/python )
llvm.org_set_globals
python_test() {
+ # tests rely on results from a specific clang version, so override
+ # the search path
+ local -x CLANG_LIBRARY_PATH=${BROOT}/usr/lib/llvm/${PV%%.*}/$(get_libdir)
"${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
}
diff --git a/dev-python/clang-python/clang-python-16.0.0_pre20220918.ebuild b/dev-python/clang-python/clang-python-16.0.0_pre20220918.ebuild
index 2891edc42793..f0290ca4c7b1 100644
--- a/dev-python/clang-python/clang-python-16.0.0_pre20220918.ebuild
+++ b/dev-python/clang-python/clang-python-16.0.0_pre20220918.ebuild
@@ -29,12 +29,18 @@ RDEPEND="
"
BDEPEND="
${PYTHON_DEPS}
+ test? (
+ sys-devel/clang:${PV%%.*}
+ )
"
LLVM_COMPONENTS=( clang/bindings/python )
llvm.org_set_globals
python_test() {
+ # tests rely on results from a specific clang version, so override
+ # the search path
+ local -x CLANG_LIBRARY_PATH=${BROOT}/usr/lib/llvm/${PV%%.*}/$(get_libdir)
"${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
}