summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-28 07:59:38 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-28 08:53:21 +0200
commitc0d02bcab11f3894d7a17458d5ab5225eb55e287 (patch)
tree3538d2fbb0a3122d3815487cabcd8675e2e46d9e /dev-python/cli_helpers
parentdev-python/tldextract: Bump to 3.1.1 (diff)
downloadgentoo-c0d02bcab11f3894d7a17458d5ab5225eb55e287.tar.gz
gentoo-c0d02bcab11f3894d7a17458d5ab5225eb55e287.tar.bz2
gentoo-c0d02bcab11f3894d7a17458d5ab5225eb55e287.zip
dev-python/cli_helpers: Bump to 2.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cli_helpers')
-rw-r--r--dev-python/cli_helpers/Manifest1
-rw-r--r--dev-python/cli_helpers/cli_helpers-2.2.0.ebuild24
-rw-r--r--dev-python/cli_helpers/cli_helpers-9999.ebuild5
3 files changed, 27 insertions, 3 deletions
diff --git a/dev-python/cli_helpers/Manifest b/dev-python/cli_helpers/Manifest
index c9182e19c8c0..c760fe582011 100644
--- a/dev-python/cli_helpers/Manifest
+++ b/dev-python/cli_helpers/Manifest
@@ -1 +1,2 @@
DIST cli_helpers-2.1.0.tar.gz 32967 BLAKE2B c2ee2a92dce4185f656415d6079196953c5e9dccf9de4e29d9de61bf72b041a6225ffe4afa866b0f78abcd5d0809ec739db489aee21e440575b7e2a6e09b916a SHA512 75c6b24ae1ed05cbdfddfc30c5e43aeb7129f5fa319d485e19be098691762ad681c4874449b2f339f833424a970965b5a28a3b66814cb556ea8ad6293740fdbe
+DIST cli_helpers-2.2.0.tar.gz 34018 BLAKE2B c7dfe8b87db6312557b4ac87aa4eda77b94f12789fcd4a9e686cada47bd41601f5c357a77de4a1c6d550b2ea110b682da0a04edb312d26ecf281e6d323369462 SHA512 26d78227999e8bb37f58529ce29bbed1bc8d51c80f81127552fb1d1f880c476abdd43ca628c591ba50c0316b35d1df0541906bf902a7549f459da0e1200c8479
diff --git a/dev-python/cli_helpers/cli_helpers-2.2.0.ebuild b/dev-python/cli_helpers/cli_helpers-2.2.0.ebuild
new file mode 100644
index 000000000000..a558d553a0bc
--- /dev/null
+++ b/dev-python/cli_helpers/cli_helpers-2.2.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python helpers for common CLI tasks"
+HOMEPAGE="https://cli-helpers.rtfd.io/"
+SRC_URI="https://github.com/dbcli/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/configobj-5.0.5[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.8.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/cli_helpers/cli_helpers-9999.ebuild b/dev-python/cli_helpers/cli_helpers-9999.ebuild
index f36ceb139659..58df205d42ff 100644
--- a/dev-python/cli_helpers/cli_helpers-9999.ebuild
+++ b/dev-python/cli_helpers/cli_helpers-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..10} )
+PYTHON_COMPAT=( python3_{8..10} )
EGIT_REPO_URI="https://github.com/dbcli/${PN}.git"
inherit distutils-r1 git-r3
@@ -19,7 +19,6 @@ RDEPEND="
>=dev-python/configobj-5.0.5[${PYTHON_USEDEP}]
>=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
>=dev-python/tabulate-0.8.0[${PYTHON_USEDEP}]
- >=dev-python/terminaltables-3.0.0[${PYTHON_USEDEP}]
dev-python/wcwidth[${PYTHON_USEDEP}]
"