summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-08-20 22:01:47 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-08-20 22:09:56 -0400
commit286e381adeb19a016ab6201f6ea7200c24e2b598 (patch)
treec0b17f1e40c62526f85d7ef0c6170ea02c6083fd /dev-python/click
parentdev-python/pytest-xprocess: add python 3.7 support (diff)
downloadgentoo-286e381adeb19a016ab6201f6ea7200c24e2b598.tar.gz
gentoo-286e381adeb19a016ab6201f6ea7200c24e2b598.tar.bz2
gentoo-286e381adeb19a016ab6201f6ea7200c24e2b598.zip
dev-python/click: add python 3.7 support
Package-Manager: Portage-2.3.47, Repoman-2.3.10
Diffstat (limited to 'dev-python/click')
-rw-r--r--dev-python/click/click-6.7-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/click/click-6.7-r1.ebuild b/dev-python/click/click-6.7-r1.ebuild
new file mode 100644
index 000000000000..ebdcd6be3d0e
--- /dev/null
+++ b/dev-python/click/click-6.7-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package for creating beautiful command line interfaces"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="http://click.pocoo.org/ https://pypi.org/project/click/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc examples test"
+
+REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ # From upstream, can be removed in next release.
+ "${FILESDIR}/${PN}-6.7-fix-tests.patch"
+)
+
+pkg_setup() {
+ use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
+}
+
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}