summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-03 04:37:14 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-03 04:37:14 +0100
commitf668b834decc42a76e40045afeeb24b2e15da930 (patch)
treeb462e295548a0f4f6737181d577617a5bf9f8641 /dev-python/cmd2
parentdev-python/pysnmp: Bump to 7.1.9 (diff)
downloadgentoo-f668b834decc42a76e40045afeeb24b2e15da930.tar.gz
gentoo-f668b834decc42a76e40045afeeb24b2e15da930.tar.bz2
gentoo-f668b834decc42a76e40045afeeb24b2e15da930.zip
dev-python/cmd2: Bump to 2.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cmd2')
-rw-r--r--dev-python/cmd2/Manifest1
-rw-r--r--dev-python/cmd2/cmd2-2.5.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/cmd2/Manifest b/dev-python/cmd2/Manifest
index d34c304b783b..d66c0db1ac9d 100644
--- a/dev-python/cmd2/Manifest
+++ b/dev-python/cmd2/Manifest
@@ -1,2 +1,3 @@
DIST cmd2-2.4.3.tar.gz 678661 BLAKE2B 806fbd6abc26737032dd6330ebabc1e5308e9082f9c98002845a54f1458d314feb476e4d491892e74cde16f5043c57495426ad50aaf3e7e8d0d938f0388db6e2 SHA512 1d440752262f38a742069e636373884edcc49c17ba17b21b24015cfe559b4df36b45ac9489f2f643897fbd38f54b8e6120daf07ef25d2f209af8a4ac8e4c0085
DIST cmd2-2.5.0.tar.gz 688531 BLAKE2B b5b88faf2848b8941df70235c32451847c86dbc7953b960383e57fa1529d4d3c557d75a36010900f7702c68b3f46de1725fb4b74892073b0dcd975b4f880e9cb SHA512 7c04cb735624abdd8ba93aa7dd5155913fe6bd9f2021c58008a20e91c380fed87c1bb32b552be6b7ab47ceca49bc5dced9e31fe7a5a0b621475862b28216f4ee
+DIST cmd2-2.5.1.tar.gz 984750 BLAKE2B 3da891b3ba5b6b4ac85511830d79bb339a4cc33c2aa7d85b6f4143f533b53b3786a8d2034c062f36909eb8a15efcf8451c19a5d9a6beb4c7f122933482058041 SHA512 703f5d0aca1006f94c5971815c8b18e40d186f906d782fb6386d5d50c08f03535c8dc1577fc6b2f67fca207d414c01223f5efa2adeafe121217b2a0158deec94
diff --git a/dev-python/cmd2/cmd2-2.5.1.ebuild b/dev-python/cmd2/cmd2-2.5.1.ebuild
new file mode 100644
index 000000000000..820c48bb0ffa
--- /dev/null
+++ b/dev-python/cmd2/cmd2-2.5.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 virtualx pypi
+
+DESCRIPTION="Extra features for standard library's cmd module"
+HOMEPAGE="
+ https://github.com/python-cmd2/cmd2/
+ https://pypi.org/project/cmd2/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pyperclip[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+# pyperclip uses clipboard backends in the following preference order:
+# pygtk, xclip, xsel, klipper, qtpy, pyqt5, pyqt4.
+# klipper is known to be broken in Xvfb, and therefore causes test
+# failures. to avoid them, we must ensure that one of the backends
+# preferred to it is available (i.e. xclip or xsel).
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ || (
+ x11-misc/xclip
+ x11-misc/xsel
+ )
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ # tests rely on very specific text wrapping...
+ local -x COLUMNS=80
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # TODO: tests_isolated?
+ epytest -o addopts= -p pytest_mock tests || die
+}