summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-13 07:40:29 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-13 07:51:43 +0100
commit1474874edcfaba9f4e78e64197d268160c2126dd (patch)
treef35ddf393631fa06ac5b488d44f4c9869bbc4d1b /dev-python/comm/comm-0.2.2.ebuild
parentdev-python/python-novaclient: Bump to 18.6.0 (diff)
downloadgentoo-1474874edcfaba9f4e78e64197d268160c2126dd.tar.gz
gentoo-1474874edcfaba9f4e78e64197d268160c2126dd.tar.bz2
gentoo-1474874edcfaba9f4e78e64197d268160c2126dd.zip
dev-python/comm: Bump to 0.2.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/comm/comm-0.2.2.ebuild')
-rw-r--r--dev-python/comm/comm-0.2.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/comm/comm-0.2.2.ebuild b/dev-python/comm/comm-0.2.2.ebuild
new file mode 100644
index 000000000000..6ddbbf5df8d5
--- /dev/null
+++ b/dev-python/comm/comm-0.2.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter Python Comm implementation, for usage in ipykernel, xeus-python"
+HOMEPAGE="
+ https://github.com/ipython/comm/
+ https://pypi.org/project/comm/
+"
+# no tests in sdist, as of 0.1.3
+SRC_URI="
+ https://github.com/ipython/comm/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/traitlets-4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest