summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-24 09:11:40 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-24 10:26:02 +0200
commite1b93ac23444a7445170d47a378769dfb7920590 (patch)
tree4d0f9b29577da36d028648ee53300152b9061ff5 /dev-python/contourpy
parentmedia-gfx/photoqt: Add missing DEPEND (diff)
downloadgentoo-e1b93ac23444a7445170d47a378769dfb7920590.tar.gz
gentoo-e1b93ac23444a7445170d47a378769dfb7920590.tar.bz2
gentoo-e1b93ac23444a7445170d47a378769dfb7920590.zip
dev-python/contourpy: New dep of matplotlib, v1.0.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/contourpy')
-rw-r--r--dev-python/contourpy/Manifest1
-rw-r--r--dev-python/contourpy/contourpy-1.0.5.ebuild47
-rw-r--r--dev-python/contourpy/metadata.xml12
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/contourpy/Manifest b/dev-python/contourpy/Manifest
new file mode 100644
index 000000000000..c5ba47fdafc3
--- /dev/null
+++ b/dev-python/contourpy/Manifest
@@ -0,0 +1 @@
+DIST contourpy-1.0.5.gh.tar.gz 12153420 BLAKE2B 1b3899831938c114480606f0c2ef2962248721884cd2be727f2bd11d12d322e7652c7b63860f4c5d8bd039a7e838f3f360dd1af017219caa97dfc63d69ef7e19 SHA512 47dc08f02920cb0ffc081f313dd041fa36e2fd0a81530374ae77adc288af13cf2c526fc1f45d06ef1c256c4c8fe243e0b36b54d3fff7d4f8bd6f9f4938d3c805
diff --git a/dev-python/contourpy/contourpy-1.0.5.ebuild b/dev-python/contourpy/contourpy-1.0.5.ebuild
new file mode 100644
index 000000000000..9ccea39952a2
--- /dev/null
+++ b/dev-python/contourpy/contourpy-1.0.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for calculating contours in 2D quadrilateral grids"
+HOMEPAGE="
+ https://pypi.org/project/contourpy/
+ https://github.com/contourpy/contourpy/
+"
+SRC_URI="
+ https://github.com/contourpy/contourpy/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/numpy-1.16[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pybind11-2.6[${PYTHON_USEDEP}]
+ test? (
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # linters
+ tests/test_codebase.py
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # threaded algorithms are known to be broken
+ # https://github.com/contourpy/contourpy/issues/163
+ epytest -k "not threaded and not threads"
+}
diff --git a/dev-python/contourpy/metadata.xml b/dev-python/contourpy/metadata.xml
new file mode 100644
index 000000000000..ebd4ed83a551
--- /dev/null
+++ b/dev-python/contourpy/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">contourpy/contourpy</remote-id>
+ <remote-id type="pypi">contourpy</remote-id>
+ </upstream>
+</pkgmetadata>