summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-01 04:08:14 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-01 05:01:13 +0200
commit5064d022305cb0b915b5924d5864401566e58164 (patch)
tree8a471c3a30347ab19f258de9abc2a5ffb6a519d2 /dev-python/curtsies
parentapp-admin/awscli: Bump to 1.29.16 (diff)
downloadgentoo-5064d022305cb0b915b5924d5864401566e58164.tar.gz
gentoo-5064d022305cb0b915b5924d5864401566e58164.tar.bz2
gentoo-5064d022305cb0b915b5924d5864401566e58164.zip
dev-python/curtsies: Bump to 0.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/curtsies')
-rw-r--r--dev-python/curtsies/Manifest1
-rw-r--r--dev-python/curtsies/curtsies-0.4.2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/curtsies/Manifest b/dev-python/curtsies/Manifest
index 5a78aa4d93f2..14af7423960c 100644
--- a/dev-python/curtsies/Manifest
+++ b/dev-python/curtsies/Manifest
@@ -1 +1,2 @@
DIST curtsies-0.4.1.tar.gz 53583 BLAKE2B 311c538dfc782566fefeac5bc085fda57200f1d42118393aee1de89486100d9777d6b5c9de8d7dda9a8d3e8564b56cfeb2cde8d1ed638d5f791e24f37eff7a02 SHA512 f49c5874b0e0e4cf92b05ca979bed8608e5e4e4bebfc78f8558e8b32b06876e680fe4d6bb8723bb2050ab3eed0b5379d065c69a3007e6c399b4f60bd410fc947
+DIST curtsies-0.4.2.tar.gz 53559 BLAKE2B b1e6a0b736615c890a35fba0dae2914e51123976c884d253e61e2e4f04cff9398fa9668387b9503a064aa76664c339d5be000e8e172c23a82cafbf3b7523beb3 SHA512 0740b50001a65da7afcb634d99ab03612be0c379035bc15f591a70dc006b46476d38a1c4b107ff17a12d696ce127027c3e13763dfd16dc223628a27611e071e3
diff --git a/dev-python/curtsies/curtsies-0.4.2.ebuild b/dev-python/curtsies/curtsies-0.4.2.ebuild
new file mode 100644
index 000000000000..cf6d0743b0a1
--- /dev/null
+++ b/dev-python/curtsies/curtsies-0.4.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Curses-like terminal wrapper, with colored strings"
+HOMEPAGE="
+ https://github.com/bpython/curtsies/
+ https://pypi.org/project/curtsies/
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/blessed-1.5[${PYTHON_USEDEP}]
+ dev-python/cwcwidth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pyte[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest