summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2021-04-15 12:11:59 +0300
committerSergey Popov <pinkbyte@gentoo.org>2021-04-15 12:13:22 +0300
commit5825a4c61fc12db62e869431ff41844a5760eaec (patch)
treef82ea492c8e456fb26c5cf27061595e164d8fa29 /dev-python/cx_Freeze
parentdev-python/cx_Freeze: add missing dependency for dev-python/importlib_metadata (diff)
downloadgentoo-5825a4c61fc12db62e869431ff41844a5760eaec.tar.gz
gentoo-5825a4c61fc12db62e869431ff41844a5760eaec.tar.bz2
gentoo-5825a4c61fc12db62e869431ff41844a5760eaec.zip
dev-python/cx_Freeze: version bump
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Sergey Popov <pinkbyte@gentoo.org>
Diffstat (limited to 'dev-python/cx_Freeze')
-rw-r--r--dev-python/cx_Freeze/Manifest1
-rw-r--r--dev-python/cx_Freeze/cx_Freeze-6.6.ebuild29
-rw-r--r--dev-python/cx_Freeze/files/cx_Freeze-6.6-buildsystem.patch11
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/cx_Freeze/Manifest b/dev-python/cx_Freeze/Manifest
index 26e494bb1c38..de67cbecd27c 100644
--- a/dev-python/cx_Freeze/Manifest
+++ b/dev-python/cx_Freeze/Manifest
@@ -1 +1,2 @@
DIST cx_Freeze-6.5.3.tar.gz 112334 BLAKE2B 77558e35ca13bc598a810ea70acfe59901c036daf37b2f9582c4f2761680d54d5be559e9abbf16bd995d7f4a4e7bd5d8793e0b53c24111767d54a69c633c9b46 SHA512 37ba5c920306ff62a21ab46c1b9fd6b1780864095d00223776c308fa28e60a5473c74e7da4e7478725de14b7f5628d8d8445f42c0671bc502e5e2d8ecb5ffae5
+DIST cx_Freeze-6.6.tar.gz 120239 BLAKE2B f4ba5de3f4233ee5417d1e1dfb8ad23180d59bf7b2b2da4918c390d69e6f73cb814a1063951b2564bd4f8eabe8aff5faf9f731fe500bf90b4a5ef8cd081632a4 SHA512 24305f19c10d13ea58d995d80dc43c884898ae1e29a470d2885b6d7448806103bc7771874cc6dd064114c6e5e59f351dfec71c37ef3dddc0a136bb5a166cdb3a
diff --git a/dev-python/cx_Freeze/cx_Freeze-6.6.ebuild b/dev-python/cx_Freeze/cx_Freeze-6.6.ebuild
new file mode 100644
index 000000000000..15f968f597c9
--- /dev/null
+++ b/dev-python/cx_Freeze/cx_Freeze-6.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python{3_7,3_8,3_9} )
+inherit distutils-r1
+
+DESCRIPTION="Create standalone executables from Python scripts"
+HOMEPAGE="https://cx-freeze.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PYTHON"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ dev-util/patchelf
+"
+
+PATCHES=(
+ # bug #491602
+ "${FILESDIR}/${PN}-6.6-buildsystem.patch"
+)
+
+# bug #765385
+RESTRICT="test"
diff --git a/dev-python/cx_Freeze/files/cx_Freeze-6.6-buildsystem.patch b/dev-python/cx_Freeze/files/cx_Freeze-6.6-buildsystem.patch
new file mode 100644
index 000000000000..93c0ff052e6f
--- /dev/null
+++ b/dev-python/cx_Freeze/files/cx_Freeze-6.6-buildsystem.patch
@@ -0,0 +1,11 @@
+--- a/setup.py 2021-04-15 11:18:45.040000000 +0300
++++ b/setup.py 2021-04-15 11:18:59.880000000 +0300
+@@ -87,8 +87,6 @@
+ if "--with-lto" in get_config_var("CONFIG_ARGS"):
+ extra_args.append("-flto")
+ extra_args.append("-Wl,-export_dynamic")
+- else:
+- extra_args.append("-s")
+ extra_args.append("-Wl,-rpath,$ORIGIN/lib")
+ extra_args.append("-Wl,-rpath,$ORIGIN/../lib")
+ self.compiler.link_executable(