summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-14 16:31:10 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-14 18:04:08 +0100
commitcbd421246ec2ccde8821fac381636a836ab6c1d1 (patch)
treefbf51a55e0f5d28ecb855c3cc70ead656752494f /dev-python/debtcollector
parentdev-python/openstackdocstheme: Bump to 2.4.0 (diff)
downloadgentoo-cbd421246ec2ccde8821fac381636a836ab6c1d1.tar.gz
gentoo-cbd421246ec2ccde8821fac381636a836ab6c1d1.tar.bz2
gentoo-cbd421246ec2ccde8821fac381636a836ab6c1d1.zip
dev-python/debtcollector: Bump to 2.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/debtcollector')
-rw-r--r--dev-python/debtcollector/Manifest1
-rw-r--r--dev-python/debtcollector/debtcollector-2.5.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/debtcollector/Manifest b/dev-python/debtcollector/Manifest
index 89e697a12f6c..94159b144b4f 100644
--- a/dev-python/debtcollector/Manifest
+++ b/dev-python/debtcollector/Manifest
@@ -1 +1,2 @@
DIST debtcollector-2.4.0.tar.gz 31376 BLAKE2B ccd34005133a888b164538c01ed482da26e91e2dd5d9f11bb0efacc0941c9eb1c0357ce8d0c237734ad450226512263ba8aa52f3b8e712a33a40fac384db2791 SHA512 31287e223524d5997e9dc776766c5ab2ec77c771fca6e9b27e058fdd94a20b67a73147c538f9a7a3155c4ce6eb85a20e8276bedd1a53a81bebcb5daaceb1b463
+DIST debtcollector-2.5.0.tar.gz 31334 BLAKE2B 1f06725ead19e36e6feda1c8666403e536d5f39f775d9a9929a06ea053be41e64575a4e4d28b3a0032610cdd7f68f35bf54ff2445543c4b8ec667732e1a8d5ea SHA512 3f1378c52994a0320b8abd997a1b240496f6f12d29e8b08612bb97c7c8d2993b23224be62cbe4eaa556dcd5a3c7a4a8f8ea4873688e1aad2f26bb5ba522c1d6a
diff --git a/dev-python/debtcollector/debtcollector-2.5.0.ebuild b/dev-python/debtcollector/debtcollector-2.5.0.ebuild
new file mode 100644
index 000000000000..82200b8255ef
--- /dev/null
+++ b/dev-python/debtcollector/debtcollector-2.5.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python deprecation patterns and strategies that collect technical debt"
+HOMEPAGE="https://www.openstack.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/subunit[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest