summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-13 04:41:20 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-13 04:41:20 +0200
commit868fd2a52e7d4678599006d097ede1c79b7bd739 (patch)
tree9727c9fc43eeacea308993104f2bc9115ea9515c /dev-python/deepdiff
parentdev-python/flask-migrate: Bump to 4.0.5 (diff)
downloadgentoo-868fd2a52e7d4678599006d097ede1c79b7bd739.tar.gz
gentoo-868fd2a52e7d4678599006d097ede1c79b7bd739.tar.bz2
gentoo-868fd2a52e7d4678599006d097ede1c79b7bd739.zip
dev-python/deepdiff: Bump to 6.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/deepdiff')
-rw-r--r--dev-python/deepdiff/Manifest1
-rw-r--r--dev-python/deepdiff/deepdiff-6.5.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/deepdiff/Manifest b/dev-python/deepdiff/Manifest
index b6a3e6cbb83b..35de30568b46 100644
--- a/dev-python/deepdiff/Manifest
+++ b/dev-python/deepdiff/Manifest
@@ -1,3 +1,4 @@
DIST deepdiff-6.3.1.tar.gz 392651 BLAKE2B 605dddc7c9d5895388141cbd3ed1a566c0631050719f3bd849578d40497323c0e9c117a8b4c73b21010600caec775f7c226818d0f15f4f1a8f4c3829414323ce SHA512 13d9edf42eb50b6e63e038a2c17d7d54e82e5e6b5ddc3420cc457d91e220da92391b17c238ed3a49d0f69168cad887c2278182734be23265d5c53928b28c4c42
DIST deepdiff-6.4.0.tar.gz 394464 BLAKE2B dce005461b4ce1c4b84b9093ba445b11a96b91bf4aab302ae76fc98066c9c3d9871fe79de5f0254451e4bd9b7dc623268d375b681fea69988392e04385777818 SHA512 af4fb42180959df2dbd7708d87d8b1cd49e8cde058a705e45e78da188668cb42e65e9ddabb120fa9ab71bb8f45d3e8a9293c5e3568b9d49af6b326d4a21e27e4
DIST deepdiff-6.4.1.tar.gz 394531 BLAKE2B a95b18bf335e88beb2ee19209fa9166fe2c0c65a5312ee4283b03e745c0469913ccf3b132042c7173a518416f8d227da24f8c3aa3dd91d916ac67fb190b9bf54 SHA512 3e54313b4681b75d607ad2eb2485245f43d78f0a80adf2f50847fd9a241cb1752cf66028a3cb5dc2980786e1c9de35fa9da52df8ed434ca2f889d99250088f66
+DIST deepdiff-6.5.0.tar.gz 395348 BLAKE2B e7a509ac1950da7ba2c3d12c85eb80d03b8f78229c5a041d14aee8368d8a2a071a0afc8cad0425f23eda82d3f5038d9340c8ed2870f637fd9bb2665cd15be67f SHA512 857d1e0e34ab85c67c5b655fe245f4aba4de3620ad39e1f044bf6329b0ecd0afeeb9511a318badadb21daac03594844d6c6357c91a8056e44e67e83e4635f26b
diff --git a/dev-python/deepdiff/deepdiff-6.5.0.ebuild b/dev-python/deepdiff/deepdiff-6.5.0.ebuild
new file mode 100644
index 000000000000..e41b020f504f
--- /dev/null
+++ b/dev-python/deepdiff/deepdiff-6.5.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A library for comparing dictionaries, iterables, strings and other objects"
+HOMEPAGE="
+ https://github.com/seperman/deepdiff/
+ https://pypi.org/project/deepdiff/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pyyaml-6.0[${PYTHON_USEDEP}]
+ >=dev-python/click-8.1.3[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ test? (
+ >=dev-python/jsonpickle-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.23.5[${PYTHON_USEDEP}]
+ dev-python/pydantic[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/tomli-w[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+ )
+"
+
+distutils_enable_tests pytest