summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-02-14 19:55:50 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-02-14 19:55:50 +0100
commite7eb0d65b6b69760741bb3b729e4e35c5c5b29b0 (patch)
tree34821644a25729d270a3a395c26c20fc864b380f /dev-python/defusedxml
parentkde-misc/kio-gdrive: 1.1.1 version bump (diff)
downloadgentoo-e7eb0d65b6b69760741bb3b729e4e35c5c5b29b0.tar.gz
gentoo-e7eb0d65b6b69760741bb3b729e4e35c5c5b29b0.tar.bz2
gentoo-e7eb0d65b6b69760741bb3b729e4e35c5c5b29b0.zip
dev-python/defusedxml: Version bump to 0.5.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/defusedxml')
-rw-r--r--dev-python/defusedxml/Manifest1
-rw-r--r--dev-python/defusedxml/defusedxml-0.5.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/defusedxml/Manifest b/dev-python/defusedxml/Manifest
index ed7fd2fae288..cf03d0bac56e 100644
--- a/dev-python/defusedxml/Manifest
+++ b/dev-python/defusedxml/Manifest
@@ -1 +1,2 @@
DIST defusedxml-0.4.1.tar.gz 48889 SHA256 cd551d5a518b745407635bb85116eb813818ecaf182e773c35b36239fc3f2478 SHA512 78a7a1f3d1eed9d7cda00afaaccf8153c7f616303c53d3918341d75970d532932b04effcfc8b1b8ed88ba6d730cb56400e9e4ecee8aa7d2181c7577f1d535783 WHIRLPOOL 9f3f51af296e3fd16b2cd94029481fbabb687c986f39810dcba331c9d3e5e30e0b294f9f1f5ce031ea28053f33be1a13e89d65ef7d0c6a3333e81dc764868d7e
+DIST defusedxml-0.5.0.tar.gz 60405 SHA256 24d7f2f94f7f3cb6061acb215685e5125fbcdc40a857eff9de22518820b0a4f4 SHA512 71e1a604df9be41ded454bcdfa63610e897eb405295d7365fcddfc5f50f7572c36f0bd91a4a1fdf47d1b097637bd9fdcf08f1cdb73e2fe64eea0320a7532e452 WHIRLPOOL c215dd919fba36de5e12443d556fb9a9c805d4d9aa3ddc75215c47c1b80861cef4bb564f25f67dbdc91927e5928a27c5585b8635a8bbd7d04c721b4db9b96410
diff --git a/dev-python/defusedxml/defusedxml-0.5.0.ebuild b/dev-python/defusedxml/defusedxml-0.5.0.ebuild
new file mode 100644
index 000000000000..33ce1499982c
--- /dev/null
+++ b/dev-python/defusedxml/defusedxml-0.5.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="XML bomb protection for Python stdlib modules, an xml serialiser"
+HOMEPAGE="https://bitbucket.org/tiran/defusedxml"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="examples"
+
+LICENSE="PSF-2"
+SLOT="0"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( other/. )
+ distutils-r1_python_install_all
+}