summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-19 17:56:54 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-19 18:05:15 +0200
commit1922813dcd8e43e94627300b84205029fc386675 (patch)
tree5492a8dfacff1ee3d4d8b5c76f08b0ee5971efcf /dev-python/distlib
parentdev-python/black: Stabilize 23.7.0 arm64, #912597 (diff)
downloadgentoo-1922813dcd8e43e94627300b84205029fc386675.tar.gz
gentoo-1922813dcd8e43e94627300b84205029fc386675.tar.bz2
gentoo-1922813dcd8e43e94627300b84205029fc386675.zip
dev-python/distlib: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/distlib')
-rw-r--r--dev-python/distlib/Manifest1
-rw-r--r--dev-python/distlib/distlib-0.3.6.ebuild58
-rw-r--r--dev-python/distlib/files/distlib-0.3.6-py312.patch50
3 files changed, 0 insertions, 109 deletions
diff --git a/dev-python/distlib/Manifest b/dev-python/distlib/Manifest
index 49c37a1cf363..935acdf8925a 100644
--- a/dev-python/distlib/Manifest
+++ b/dev-python/distlib/Manifest
@@ -1,2 +1 @@
-DIST distlib-0.3.6.gh.tar.gz 1234082 BLAKE2B 384b736d9fb9e63d1b9a9375caf972ddfccb36c99903928505e684fe09b30190f873cf7b109beb6c32a1e4b1e11a1d9947adea74f9dceef3398fcc1963a2044a SHA512 39948539764ff5d45f14dc602ebd47d523b71b587ee081d7a267669aef4e4b1013d3995cb992038136bc4c01826ea633c6e4ffd050f1511705b296bf76f3bbf9
DIST distlib-0.3.7.gh.tar.gz 1240451 BLAKE2B 2050133ae1f57a2b37013e0e49a22903a816377d111e6a35c57084e2dd7877b41e9625e3cccbc9e67c35239814b835b064f94eec8bcd41dedd7d329f9d5be2ec SHA512 33806fd953c4b185eaa69c7d0f0cdad9ea71be73d26f0585cefd4a332edbcc3c6287b3bce024858d5d15626311f2567474b19b6366f80b2336d9b39691c6fe31
diff --git a/dev-python/distlib/distlib-0.3.6.ebuild b/dev-python/distlib/distlib-0.3.6.ebuild
deleted file mode 100644
index 2fb434b9de26..000000000000
--- a/dev-python/distlib/distlib-0.3.6.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Low-level components of distutils2/packaging"
-HOMEPAGE="
- https://pypi.org/project/distlib/
- https://github.com/pypa/distlib
-"
-SRC_URI="
- https://github.com/pypa/distlib/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
-"
-
-LICENSE="PSF-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# pypiserver is called as external executable
-BDEPEND="
- test? (
- dev-python/pypiserver
- )
-"
-
-src_prepare() {
- local PATCHES=(
- "${FILESDIR}/${P}-py312.patch"
-
- # use system pypiserver instead of bundled one
- "${FILESDIR}"/distlib-0.3.2-system-pypiserver.py
- )
-
- # make sure they're not used
- rm tests/pypi-server-standalone.py || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- local -x SKIP_ONLINE=1
- local -x PYTHONHASHSEED=0
-
- # disable system-site-packages -- distlib has no deps, and is very
- # fragile to packages actually installed on the system
- sed -i -e '/system-site-packages/s:true:false:' \
- "${BUILD_DIR}/install${EPREFIX}/usr/bin/pyvenv.cfg" || die
-
- "${EPYTHON}" tests/test_all.py -v -x ||
- die "Tests failed with ${EPYTHON}"
-}
diff --git a/dev-python/distlib/files/distlib-0.3.6-py312.patch b/dev-python/distlib/files/distlib-0.3.6-py312.patch
deleted file mode 100644
index 4e1d8927b745..000000000000
--- a/dev-python/distlib/files/distlib-0.3.6-py312.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From fe769c72e4f9d613b2ce066325d2fb28317833d5 Mon Sep 17 00:00:00 2001
-From: Lumir Balhar <lbalhar@redhat.com>
-Date: Thu, 18 May 2023 14:09:34 +0200
-Subject: [PATCH 1/2] Check for cert_file attribute before accessing it
-
-In Python 3.12, HTTPSConnection no longer has cert_file attribute
-so unless something adds it to the subclass, the attribute doesn't
-exist by default.
-
-CPython change: https://github.com/python/cpython/commit/ef0e72b31d22f780d3a165d7d0471806061fe380#diff-3cf29d90eb758d0fe5ec013bbfda9b0bb60be4f7d899583bd5f490a7a5a5dc5f
----
- distlib/util.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/distlib/util.py b/distlib/util.py
-index dd01849..ddfc992 100644
---- a/distlib/util.py
-+++ b/distlib/util.py
-@@ -1435,7 +1435,7 @@ def connect(self):
- context = ssl.SSLContext(ssl.PROTOCOL_SSLv23)
- if hasattr(ssl, 'OP_NO_SSLv2'):
- context.options |= ssl.OP_NO_SSLv2
-- if self.cert_file:
-+ if hasattr(self, "cert_file") and self.cert_file:
- context.load_cert_chain(self.cert_file, self.key_file)
- kwargs = {}
- if self.ca_certs:
-
-From 440a7b57b9521ba2eca749e26945eaf16bc7c472 Mon Sep 17 00:00:00 2001
-From: Vinay Sajip <vinay_sajip@yahoo.co.uk>
-Date: Wed, 24 May 2023 15:50:44 +0100
-Subject: [PATCH 2/2] Use single quotes.
-
----
- distlib/util.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/distlib/util.py b/distlib/util.py
-index ddfc992..d1ec58a 100644
---- a/distlib/util.py
-+++ b/distlib/util.py
-@@ -1435,7 +1435,7 @@ def connect(self):
- context = ssl.SSLContext(ssl.PROTOCOL_SSLv23)
- if hasattr(ssl, 'OP_NO_SSLv2'):
- context.options |= ssl.OP_NO_SSLv2
-- if hasattr(self, "cert_file") and self.cert_file:
-+ if hasattr(self, 'cert_file') and self.cert_file:
- context.load_cert_chain(self.cert_file, self.key_file)
- kwargs = {}
- if self.ca_certs: