summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-30 17:54:35 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-30 17:59:38 +0200
commit1910d8b53a2481eeeea3fe9feb1c6c3c2f888281 (patch)
tree230d54d3e63d36e4b238da6063005058524d20d8 /dev-python/django-debug-toolbar
parentnet-wireless/uhd: keyword 4.2.0.0 for ~riscv (diff)
downloadgentoo-1910d8b53a2481eeeea3fe9feb1c6c3c2f888281.tar.gz
gentoo-1910d8b53a2481eeeea3fe9feb1c6c3c2f888281.tar.bz2
gentoo-1910d8b53a2481eeeea3fe9feb1c6c3c2f888281.zip
dev-python/django-debug-toolbar: Bump to 3.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-debug-toolbar')
-rw-r--r--dev-python/django-debug-toolbar/Manifest1
-rw-r--r--dev-python/django-debug-toolbar/django-debug-toolbar-3.3.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/django-debug-toolbar/Manifest b/dev-python/django-debug-toolbar/Manifest
index 0d527e0f4aa0..2aa96ac4a7de 100644
--- a/dev-python/django-debug-toolbar/Manifest
+++ b/dev-python/django-debug-toolbar/Manifest
@@ -1 +1,2 @@
DIST django-debug-toolbar-3.2.4.tar.gz 255283 BLAKE2B 8be7f569c7f1eab06c4a60fca19bce6c348594406cdfe6de7e6be50849272714e9f3b51db4803e7cd58e97fe44a7422b07b05b2208f4447a4d69e0b77c856cb4 SHA512 19d3ba91b8738ade108f7eaded2859ad3e4bcae7cd0115e2cf63698d1fef01773f09a05f6bc0af53f9c3d4a2a288635a5cb2d215a2eb9f8acd6c65175a1ccaef
+DIST django-debug-toolbar-3.3.tar.gz 259488 BLAKE2B ea69c02f95bc82690fbef6d826c0e48229e6ce27ec55f26cf9991736789c8e8bd0f4b180fbc1a36a3bc3f890798925e5ff2ef5bd09e6a743adb0770d53cf1e9b SHA512 e9f919f74f58345fec402d9595e739e3619cae90d03f8c5efe7b4c5c191b339e594efd4b9823b3952a3f50d3c5bb7257a0e9eb6a7e60059433a61a8f684a1b21
diff --git a/dev-python/django-debug-toolbar/django-debug-toolbar-3.3.ebuild b/dev-python/django-debug-toolbar/django-debug-toolbar-3.3.ebuild
new file mode 100644
index 000000000000..1d724aaa1b7b
--- /dev/null
+++ b/dev-python/django-debug-toolbar/django-debug-toolbar-3.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A configurable set of panels that display debug information"
+HOMEPAGE="
+ https://pypi.org/project/django-debug-toolbar/
+ https://github.com/jazzband/django-debug-toolbar/
+"
+SRC_URI="
+ https://github.com/jazzband/django-debug-toolbar/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-3.3[${PYTHON_USEDEP}]
+ >=dev-python/sqlparse-0.2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ ${RDEPEND}
+ )
+"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ emake TEST_ARGS='-v 2 tests' test
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}