summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-15 14:16:33 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-15 14:16:33 +0100
commitfc94602d9d25d5cfa4a3a6a4ca07026c604927ff (patch)
treeee80de1497717b0ba39c78dcd91178580541c6b7 /dev-python/django-mptt
parentdev-python/django-js-asset: Enable py3.11, take for python@ (diff)
downloadgentoo-fc94602d9d25d5cfa4a3a6a4ca07026c604927ff.tar.gz
gentoo-fc94602d9d25d5cfa4a3a6a4ca07026c604927ff.tar.bz2
gentoo-fc94602d9d25d5cfa4a3a6a4ca07026c604927ff.zip
dev-python/django-mptt: py3.11, PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-mptt')
-rw-r--r--dev-python/django-mptt/django-mptt-0.13.4-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/django-mptt/django-mptt-0.13.4-r1.ebuild b/dev-python/django-mptt/django-mptt-0.13.4-r1.ebuild
new file mode 100644
index 000000000000..c0dcf44e825b
--- /dev/null
+++ b/dev-python/django-mptt/django-mptt-0.13.4-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Utilities for modified preorder tree traversal and trees of Model instances"
+HOMEPAGE="
+ https://github.com/django-mptt/django-mptt/
+ https://pypi.org/project/django-mptt/
+"
+SRC_URI="
+ https://github.com/django-mptt/django-mptt/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/django-1.11[${PYTHON_USEDEP}]
+ dev-python/django-js-asset[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ "${EPYTHON}" tests/manage.py test -v2 myapp ||
+ die "Tests failed with ${EPYTHON}"
+}