summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/django-openstack-auth
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/django-openstack-auth')
-rw-r--r--dev-python/django-openstack-auth/Manifest3
-rw-r--r--dev-python/django-openstack-auth/django-openstack-auth-1.1.5.ebuild39
-rw-r--r--dev-python/django-openstack-auth/django-openstack-auth-1.2.0.ebuild48
-rw-r--r--dev-python/django-openstack-auth/django-openstack-auth-1.3.1.ebuild68
-rw-r--r--dev-python/django-openstack-auth/metadata.xml15
5 files changed, 173 insertions, 0 deletions
diff --git a/dev-python/django-openstack-auth/Manifest b/dev-python/django-openstack-auth/Manifest
new file mode 100644
index 000000000000..b120c6251721
--- /dev/null
+++ b/dev-python/django-openstack-auth/Manifest
@@ -0,0 +1,3 @@
+DIST django_openstack_auth-1.1.5.tar.gz 40893 SHA256 ad63e85575caae1107bd05afd8d27b45d4590cc1f6d3b63905959a7c457b1aef SHA512 43a95a1a5b9c24e15d4ff76660a52204c03d6679400632e870ee364c9f7de7b39128cc6acd883cd12abc80cbdfab44a3e3f2a803193eeac7d3e838be39a93ea2 WHIRLPOOL 2515c77ce6aa2c9f3e2860506ae0d5656f3dfda9bf17eb1fba5c307bf477de5aa22a3834b94c053a5f6fc439c9cf2a5b9bbeb7e87bef3bcf3e7739f55b80dd77
+DIST django_openstack_auth-1.2.0.tar.gz 75577 SHA256 5ad78e5c92502f1abfb10fd101c023adf74a3e728bd42ed19ffea2185680f9a6 SHA512 793f0763b47574574864c16c9d79787d44c84259304587b5d2b3375de04291c5d200699297960b3b3904b959ceee31f696fef2233659db9b846c6af06fd8c251 WHIRLPOOL 37632e35beb810979ffb7878c9ffed0258a64caf4a80f61050bb054d70b56e09c9f0f13dac2ce339b87ccdcbeba779893c2ce81912b95f50d52a88b947872092
+DIST django_openstack_auth-1.3.1.tar.gz 75165 SHA256 99c6e92170656eade430d31f79ddf60e66355ff7b84caf038ab1ecc879cff9ba SHA512 cf9b4a1c526f237a23dadab4a7e6a2bd1f80a8d6d89d9b83f4d0fb6fc4df80aba68ad344662fbeaddeca2ca8ec36856af1074da383368d85d56460ed199609aa WHIRLPOOL b99b9381ce9eb1357939b750a40f86373fcbbe411d90a23e15f2d1e77dcfab45e58ac69e4e774228dc1b0dc3d3a0649e451efc0f271e904a4241b06c80b4d8bd
diff --git a/dev-python/django-openstack-auth/django-openstack-auth-1.1.5.ebuild b/dev-python/django-openstack-auth/django-openstack-auth-1.1.5.ebuild
new file mode 100644
index 000000000000..48457ec18278
--- /dev/null
+++ b/dev-python/django-openstack-auth/django-openstack-auth-1.1.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django authentication backend for use with the OpenStack Keystone
+Identity backend."
+HOMEPAGE="http://django_openstack_auth.readthedocs.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/django_openstack_auth/django_openstack_auth-${PV}.tar.gz"
+S="${WORKDIR}/django_openstack_auth-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.6.0[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]
+ test? ( >=dev-python/hacking-0.8.0[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.9[${PYTHON_USEDEP}]
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/mox-0.5.3[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.2[${PYTHON_USEDEP}]
+ dev-python/oslo-sphinx[${PYTHON_USEDEP}] )"
+RDEPEND=">=dev-python/python-keystoneclient-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/django-1.4[${PYTHON_USEDEP}]
+ <dev-python/django-1.7[${PYTHON_USEDEP}]
+ >=dev-python/six-1.5.2[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" -m openstack_auth.tests.run_tests || die "Testsuite failed"
+}
diff --git a/dev-python/django-openstack-auth/django-openstack-auth-1.2.0.ebuild b/dev-python/django-openstack-auth/django-openstack-auth-1.2.0.ebuild
new file mode 100644
index 000000000000..23635efaa7eb
--- /dev/null
+++ b/dev-python/django-openstack-auth/django-openstack-auth-1.2.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django authentication backend for use with the OpenStack Keystone
+Identity backend."
+HOMEPAGE="http://django_openstack_auth.readthedocs.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/django_openstack_auth/django_openstack_auth-${PV}.tar.gz"
+S="${WORKDIR}/django_openstack_auth-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.8.0[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/hacking-0.10.0[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.11[${PYTHON_USEDEP}]
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ >=dev-python/mox3-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+ <dev-python/oslo-sphinx-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ >=dev-python/django-1.4.2[${PYTHON_USEDEP}]
+ <dev-python/django-1.8[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-1.9.3[${PYTHON_USEDEP}]
+ <dev-python/oslo-config-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" -m openstack_auth.tests.run_tests || die "Testsuite failed"
+}
diff --git a/dev-python/django-openstack-auth/django-openstack-auth-1.3.1.ebuild b/dev-python/django-openstack-auth/django-openstack-auth-1.3.1.ebuild
new file mode 100644
index 000000000000..53af5aa70a13
--- /dev/null
+++ b/dev-python/django-openstack-auth/django-openstack-auth-1.3.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Django authentication backend for use with OpenStack Keystone Identity backend"
+HOMEPAGE="http://django_openstack_auth.readthedocs.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/django_openstack_auth/django_openstack_auth-${PV}.tar.gz"
+S="${WORKDIR}/django_openstack_auth-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+CDEPEND=">=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+ <dev-python/oslo-sphinx-2.6.0[${PYTHON_USEDEP}]
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+ >=dev-python/pbr-0.11[${PYTHON_USEDEP}]
+ <dev-python/pbr-2.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/hacking-0.10.0[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.11[${PYTHON_USEDEP}]
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ >=dev-python/mox3-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}] )
+ ${CDEPEND}
+ doc? ( ${CDEPEND} )"
+RDEPEND="
+ >=dev-python/django-1.4.2[${PYTHON_USEDEP}]
+ <dev-python/django-1.8[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-1.11.0[${PYTHON_USEDEP}]
+ <dev-python/oslo-config-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # Avoid warning in doc build due to missed file
+ if use doc; then
+ mkdir doc/source/_static || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ # under sphinx-1.3.1 the build outputs a harmless warning about change of
+ # html_theme setting in conf.py. priot versions will have the right setting
+ if use doc; then
+ sphinx-build -b html -c doc/source/ doc/source/ doc/source/html || die
+ fi
+}
+
+python_test() {
+ "${PYTHON}" -m openstack_auth.tests.run_tests || die "Testsuite failed"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/source/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/django-openstack-auth/metadata.xml b/dev-python/django-openstack-auth/metadata.xml
new file mode 100644
index 000000000000..8147c037263e
--- /dev/null
+++ b/dev-python/django-openstack-auth/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ A Django authentication backend for use with the OpenStack Keystone Identity backend.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">django_openstack_auth</remote-id>
+ </upstream>
+</pkgmetadata>