summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-22 09:05:16 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-22 09:39:24 +0200
commit30ec43cb326646af86acea3186be5e5bfd5f2ca2 (patch)
tree11930e824041e2157854648d1f4d9b7efeae8d4c /dev-python/django
parentdev-python/voluptuous: Stabilize 0.12.0 ALLARCHES, #750668 (diff)
downloadgentoo-30ec43cb326646af86acea3186be5e5bfd5f2ca2.tar.gz
gentoo-30ec43cb326646af86acea3186be5e5bfd5f2ca2.tar.bz2
gentoo-30ec43cb326646af86acea3186be5e5bfd5f2ca2.zip
dev-python/django: Unbind asgiref version
Closes: https://bugs.gentoo.org/750695 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django')
-rw-r--r--dev-python/django/django-3.0.10-r1.ebuild (renamed from dev-python/django/django-3.0.10.ebuild)7
-rw-r--r--dev-python/django/django-3.1.1-r1.ebuild (renamed from dev-python/django/django-3.1.1.ebuild)7
-rw-r--r--dev-python/django/django-3.1.2-r1.ebuild (renamed from dev-python/django/django-3.1.2.ebuild)7
3 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/django/django-3.0.10.ebuild b/dev-python/django/django-3.0.10-r1.ebuild
index 44093b1ebee8..58de49705198 100644
--- a/dev-python/django/django-3.0.10.ebuild
+++ b/dev-python/django/django-3.0.10-r1.ebuild
@@ -53,6 +53,13 @@ PATCHES=(
distutils_enable_sphinx docs --no-autodoc
+src_prepare() {
+ # do not bind to a specific version
+ # https://bugs.gentoo.org/750695
+ sed -i -e 's:asgiref ~= 3.2:asgiref:' setup.py || die
+ distutils-r1_src_prepare
+}
+
python_test() {
# Tests have non-standard assumptions about PYTHONPATH,
# and don't work with ${BUILD_DIR}/lib.
diff --git a/dev-python/django/django-3.1.1.ebuild b/dev-python/django/django-3.1.1-r1.ebuild
index e13533790e62..858be5789077 100644
--- a/dev-python/django/django-3.1.1.ebuild
+++ b/dev-python/django/django-3.1.1-r1.ebuild
@@ -53,6 +53,13 @@ PATCHES=(
distutils_enable_sphinx docs --no-autodoc
+src_prepare() {
+ # do not bind to a specific version
+ # https://bugs.gentoo.org/750695
+ sed -i -e 's:asgiref ~= 3.2.10:asgiref:' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
python_test() {
# Tests have non-standard assumptions about PYTHONPATH,
# and don't work with ${BUILD_DIR}/lib.
diff --git a/dev-python/django/django-3.1.2.ebuild b/dev-python/django/django-3.1.2-r1.ebuild
index e13533790e62..858be5789077 100644
--- a/dev-python/django/django-3.1.2.ebuild
+++ b/dev-python/django/django-3.1.2-r1.ebuild
@@ -53,6 +53,13 @@ PATCHES=(
distutils_enable_sphinx docs --no-autodoc
+src_prepare() {
+ # do not bind to a specific version
+ # https://bugs.gentoo.org/750695
+ sed -i -e 's:asgiref ~= 3.2.10:asgiref:' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
python_test() {
# Tests have non-standard assumptions about PYTHONPATH,
# and don't work with ${BUILD_DIR}/lib.