summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-15 20:43:13 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-15 21:04:12 -0500
commit420eec47c0387a910b05869f0dbf5c8cced0c517 (patch)
tree573ccd495ef415ba89d7d573aa80b04253498fa6 /dev-python/doc8
parentdev-python/restructuredtext-lint: set DISTUTILS_USE_SETUPTOOLS=rdepend (diff)
downloadgentoo-420eec47c0387a910b05869f0dbf5c8cced0c517.tar.gz
gentoo-420eec47c0387a910b05869f0dbf5c8cced0c517.tar.bz2
gentoo-420eec47c0387a910b05869f0dbf5c8cced0c517.zip
dev-python/doc8: set DISTUTILS_USE_SETUPTOOLS=rdepend
Closes: https://bugs.gentoo.org/748276 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/doc8')
-rw-r--r--dev-python/doc8/doc8-0.6.0.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/dev-python/doc8/doc8-0.6.0.ebuild b/dev-python/doc8/doc8-0.6.0.ebuild
index 53aa08ff87b5..6ee20cc6bc9e 100644
--- a/dev-python/doc8/doc8-0.6.0.ebuild
+++ b/dev-python/doc8/doc8-0.6.0.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-PYTHON_COMPAT=( python3_{6,7} )
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -15,12 +16,9 @@ SLOT="0"
KEYWORDS="amd64 ~arm64 x86"
IUSE=""
-CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}"
+DEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
RDEPEND="
- ${CDEPEND}
+ >=dev-python/pbr-1.6[${PYTHON_USEDEP}]
dev-python/chardet[${PYTHON_USEDEP}]
dev-python/docutils[${PYTHON_USEDEP}]
>=dev-python/restructuredtext-lint-0.7[${PYTHON_USEDEP}]