summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-26 22:10:37 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-26 22:15:45 +0100
commit5d5a73ffc63a7211768cec3ff36e5195c1f82101 (patch)
tree92764bf672bb965c6008b570e41f1b8c27108f98 /dev-python/dogpile-cache/dogpile-cache-1.1.2.ebuild
parentdev-python/urllib3: Bump to 1.26.3 (diff)
downloadgentoo-5d5a73ffc63a7211768cec3ff36e5195c1f82101.tar.gz
gentoo-5d5a73ffc63a7211768cec3ff36e5195c1f82101.tar.bz2
gentoo-5d5a73ffc63a7211768cec3ff36e5195c1f82101.zip
dev-python/dogpile-cache: Bump to 1.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dogpile-cache/dogpile-cache-1.1.2.ebuild')
-rw-r--r--dev-python/dogpile-cache/dogpile-cache-1.1.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/dogpile-cache/dogpile-cache-1.1.2.ebuild b/dev-python/dogpile-cache/dogpile-cache-1.1.2.ebuild
new file mode 100644
index 000000000000..4174912da531
--- /dev/null
+++ b/dev-python/dogpile-cache/dogpile-cache-1.1.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A locking API for expiring values while a single thread generates a new value."
+HOMEPAGE="https://github.com/sqlalchemy/dogpile.cache"
+SRC_URI="mirror://pypi/${PN:0:1}/dogpile.cache/dogpile.cache-${PV}.tar.gz"
+S="${WORKDIR}/dogpile.cache-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/decorator-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-3.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest