summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-15 06:09:43 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-15 06:33:07 +0100
commit1afd7c1a125472894fc0a87d06e969b022460cba (patch)
treeda27590aaad8b693dd0048ee50493f2623db251d /dev-python/doublex
parentapp-admin/awscli: Bump to 1.27.91 (diff)
downloadgentoo-1afd7c1a125472894fc0a87d06e969b022460cba.tar.gz
gentoo-1afd7c1a125472894fc0a87d06e969b022460cba.tar.bz2
gentoo-1afd7c1a125472894fc0a87d06e969b022460cba.zip
dev-python/doublex: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/doublex')
-rw-r--r--dev-python/doublex/Manifest1
-rw-r--r--dev-python/doublex/doublex-1.9.5.1.ebuild59
-rw-r--r--dev-python/doublex/files/doublex-1.9.2-py310.patch33
-rw-r--r--dev-python/doublex/files/doublex-1.9.5.1-py310.patch29
4 files changed, 0 insertions, 122 deletions
diff --git a/dev-python/doublex/Manifest b/dev-python/doublex/Manifest
index c9bb57a8e4a2..bd0b79d028c3 100644
--- a/dev-python/doublex/Manifest
+++ b/dev-python/doublex/Manifest
@@ -1,2 +1 @@
-DIST doublex-1.9.5.1.tar.gz 80508 BLAKE2B 3c3e233bbe4fcc3a122430bfb826ab9824d41472e80802f0e6d345da83cbe97bb33912a831bead550299942b0087063e86839f6bf3a29a08164b6e3bf641f437 SHA512 498e8a8076ed7d3585aae7a20edf54d4143e6875cd8e7af3b47f9f9cfc612a5217d7877092c2af7f1ac80c7aad7be89946671a836fc5817de06ec541c0cb1e06
DIST python-doublex-1.9.6.1.gh.tar.gz 81848 BLAKE2B 34aa108ba12f34f18f7a7b3d12fd2a539736d95097fd3ecf5344fdac551b16717d5348da1c6e2e10e19878b82de7e9195b9bd17d526156bc13e0ad2fd789b23e SHA512 c9779c5fcde43af653c2131894da44a878acf2cc81d53f6ab89a6fde071827a22aa97ec5a51561ad8861a98623d38c75f184be6234a6a5323c52e8e538c66710
diff --git a/dev-python/doublex/doublex-1.9.5.1.ebuild b/dev-python/doublex/doublex-1.9.5.1.ebuild
deleted file mode 100644
index 779ead13891f..000000000000
--- a/dev-python/doublex/doublex-1.9.5.1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_USE_PEP517=setuptools
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="Python test doubles"
-HOMEPAGE="https://bitbucket.org/DavidVilla/python-doublex"
-SRC_URI="https://bitbucket.org/DavidVilla/python-${PN}/get/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 arm64"
-IUSE="doc test"
-
-RDEPEND="
- dev-python/pyhamcrest[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-"
-
-PATCHES=(
- # https://github.com/davidvilla/python-doublex/commit/425807d7276dcea0e0640384d65aeb15184c508c
- "${FILESDIR}/${P}-py310.patch"
-)
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Disable broken tests
- # https://bitbucket.org/DavidVilla/python-doublex/issues/5/support-for-python-36-37-38-tests-failing
- sed -i "s/test_*hamcrest_/_&/" doublex/test/report_tests.py || die
- # https://bitbucket.org/DavidVilla/python-doublex/issues/6/more-failing-tests-with-python-39
- sed -i -r "s/test_(proxyspy_get_stubbed_property|stub_property|custom_equality_comparable_objects)/_&/" \
- doublex/test/unit_tests.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
-
- distutils-r1_python_install_all
-
- rm "${ED}"/usr/README.rst || die "Couldn't remove spurious README.rst"
-}
-
-python_test() {
- epytest -o 'python_files=*_tests.py'
-}
diff --git a/dev-python/doublex/files/doublex-1.9.2-py310.patch b/dev-python/doublex/files/doublex-1.9.2-py310.patch
deleted file mode 100644
index 5d3a974a38a1..000000000000
--- a/dev-python/doublex/files/doublex-1.9.2-py310.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-commit ec3ce987a95abd951840213b77d44624b2ca5e84
-Author: Louis Sautier <sautier.louis@gmail.com>
-Date: Sat Aug 7 01:56:31 2021 +0200
-
- Support Python 3.10 by using collections.abc
-
-diff --git a/doublex/internal.py b/doublex/internal.py
-index 91f5866..072774a 100644
---- a/doublex/internal.py
-+++ b/doublex/internal.py
-@@ -20,7 +20,7 @@
-
-
- import threading
--import collections
-+import collections.abc
- import functools
- import six
-
-@@ -184,11 +184,11 @@ class Invocation(object):
- return Invocation(double, name, InvocationContext(*args, **kargs))
-
- def delegates(self, delegate):
-- if isinstance(delegate, collections.Callable):
-+ if isinstance(delegate, collections.abc.Callable):
- self.__delegate = delegate
- return
-
-- if isinstance(delegate, collections.Mapping):
-+ if isinstance(delegate, collections.abc.Mapping):
- self.__delegate = delegate.get
- return
-
diff --git a/dev-python/doublex/files/doublex-1.9.5.1-py310.patch b/dev-python/doublex/files/doublex-1.9.5.1-py310.patch
deleted file mode 100644
index e4aa9153115e..000000000000
--- a/dev-python/doublex/files/doublex-1.9.5.1-py310.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From b76a792b48109f1a10f460878fbe0fd78c41cd93 Mon Sep 17 00:00:00 2001
-From: Sebastian Pipping <sebastian@pipping.org>
-Date: Sat, 11 Feb 2023 02:00:46 +0100
-Subject: [PATCH] Fix import to collections.abc.Callable for Python >=3.10
-
-Subset of this post-1.9.5.1 upstream commit:
-https://github.com/davidvilla/python-doublex/commit/425807d7276dcea0e0640384d65aeb15184c508c
----
- doublex/internal.py | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/doublex/internal.py b/doublex/internal.py
-index a85da9f..e5b25cb 100644
---- a/doublex/internal.py
-+++ b/doublex/internal.py
-@@ -24,8 +24,8 @@ import threading
- import functools
- import six
-
--if sys.version_info < (3, 3):
-- from collection.abc import Callable as abc_Callable, Mapping as abc_Mapping
-+if sys.version_info > (3, 3):
-+ from collections.abc import Callable as abc_Callable, Mapping as abc_Mapping
- else:
- from collections import Callable as abc_Callable, Mapping as abc_Mapping
-
---
-2.39.1
-