summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-21 18:12:22 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-21 18:25:49 +0100
commit9438abdf0cdcb9cb0c8aae2b6251b4a1e4eafcb4 (patch)
treebd64ecc131bbb5dae27cb300487d35f6dc99576a /dev-python/elementpath
parentdev-python/xmlschema: New package (diff)
downloadgentoo-9438abdf0cdcb9cb0c8aae2b6251b4a1e4eafcb4.tar.gz
gentoo-9438abdf0cdcb9cb0c8aae2b6251b4a1e4eafcb4.tar.bz2
gentoo-9438abdf0cdcb9cb0c8aae2b6251b4a1e4eafcb4.zip
dev-python/elementpath: Enable tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/elementpath')
-rw-r--r--dev-python/elementpath/elementpath-1.3.1.ebuild20
1 files changed, 18 insertions, 2 deletions
diff --git a/dev-python/elementpath/elementpath-1.3.1.ebuild b/dev-python/elementpath/elementpath-1.3.1.ebuild
index 09b5ee6f3ace..4884138e8842 100644
--- a/dev-python/elementpath/elementpath-1.3.1.ebuild
+++ b/dev-python/elementpath/elementpath-1.3.1.ebuild
@@ -14,7 +14,23 @@ SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="test"
+RESTRICT="!test? ( test )"
BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]"
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # this test fails depending on system locale + requires some random
+ # locales being installed
+ sed -e 's:test_compare_strings_function:_&:' \
+ -i tests/test_xpath2_parser.py || die
+}