summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-24 08:05:22 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-24 08:41:38 +0200
commitc5b57832be357bc1b6b5e57c5f7d14292f6ec147 (patch)
treefa3829f0848a59f081720ebb619a346c10510f95 /dev-python/emoji/emoji-2.13.2.ebuild
parentdev-python/aiohttp: Bump to 3.10.6_rc2 (diff)
downloadgentoo-c5b57832be357bc1b6b5e57c5f7d14292f6ec147.tar.gz
gentoo-c5b57832be357bc1b6b5e57c5f7d14292f6ec147.tar.bz2
gentoo-c5b57832be357bc1b6b5e57c5f7d14292f6ec147.zip
dev-python/emoji: Bump to 2.13.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/emoji/emoji-2.13.2.ebuild')
-rw-r--r--dev-python/emoji/emoji-2.13.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/emoji/emoji-2.13.2.ebuild b/dev-python/emoji/emoji-2.13.2.ebuild
new file mode 100644
index 000000000000..64f8c79c701c
--- /dev/null
+++ b/dev-python/emoji/emoji-2.13.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Emoji for Python"
+HOMEPAGE="
+ https://github.com/carpedm20/emoji/
+ https://pypi.org/project/emoji/
+"
+SRC_URI="
+ https://github.com/carpedm20/emoji/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+distutils_enable_tests pytest