summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-17 07:43:51 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-17 09:34:49 +0200
commit67270963da7f95b7c01389d8897516dc48d42f8c (patch)
tree41a01e8e7ce8aadd5979ceb282b676eecd6de5d5 /dev-python/ensurepip-pip
parentdev-python/pip: Bump to 23.2 (diff)
downloadgentoo-67270963da7f95b7c01389d8897516dc48d42f8c.tar.gz
gentoo-67270963da7f95b7c01389d8897516dc48d42f8c.tar.bz2
gentoo-67270963da7f95b7c01389d8897516dc48d42f8c.zip
dev-python/ensurepip-pip: Bump to 23.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ensurepip-pip')
-rw-r--r--dev-python/ensurepip-pip/Manifest1
-rw-r--r--dev-python/ensurepip-pip/ensurepip-pip-23.2.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/ensurepip-pip/Manifest b/dev-python/ensurepip-pip/Manifest
index 568ff7432163..579a03fc281e 100644
--- a/dev-python/ensurepip-pip/Manifest
+++ b/dev-python/ensurepip-pip/Manifest
@@ -1 +1,2 @@
DIST pip-23.1.2-py3-none-any.whl 2064688 BLAKE2B 85c19cc80a59404867e7212c442e60ed6735da35d544bd23ee4cf5a1bffad4c0fab1f34a652417a181cbcb4afc9baf94682b0ec6e1fd9457eb77bc971d29e459 SHA512 a5a8feab25f01a96c2d8c4e15a001cb38c4a0a9d88563da6653239f3966324fdbe86ae0c5172cbdb1d03b863b37a37358b80e8bb9c8112bd7809fd16fb2ec776
+DIST pip-23.2-py3-none-any.whl 2085968 BLAKE2B 320f19b21253d0160d09d51e677a81fa30515a1faee07c4ed87b36a4134820d5bafcd524c099d5892b41bd7bb738a0ccc0b906d619d7e5690a8404cb78f4469a SHA512 bdd211e74fb77117f389f0789c35b163834d9a900e7615d7a1d90a9c6a62613e69552af79cc88f594890afd9189e53c55b55a50cc31d4cd18118352ecab9cf40
diff --git a/dev-python/ensurepip-pip/ensurepip-pip-23.2.ebuild b/dev-python/ensurepip-pip/ensurepip-pip-23.2.ebuild
new file mode 100644
index 000000000000..474a502c1273
--- /dev/null
+++ b/dev-python/ensurepip-pip/ensurepip-pip-23.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit pypi
+
+DESCRIPTION="Shared pip wheel for ensurepip Python module"
+HOMEPAGE="https://pypi.org/project/pip/"
+SRC_URI="$(pypi_wheel_url "${PN#ensurepip-}")"
+S=${DISTDIR}
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC LGPL-2.1+ MIT MPL-2.0 PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ !<dev-python/ensurepip-wheels-100
+"
+
+src_install() {
+ insinto /usr/lib/python/ensurepip
+ doins "${A}"
+}