summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-18 14:59:18 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-18 16:03:37 +0200
commite77b4d6257ff329ce22002240ea25356103d6f78 (patch)
tree3cd9f7acefca0f1f44f56f5c997b0cdf65ed5cdc /dev-python/filelock
parentdev-python/platformdirs: Bump to 4.3.6 (diff)
downloadgentoo-e77b4d6257ff329ce22002240ea25356103d6f78.tar.gz
gentoo-e77b4d6257ff329ce22002240ea25356103d6f78.tar.bz2
gentoo-e77b4d6257ff329ce22002240ea25356103d6f78.zip
dev-python/filelock: Bump to 3.16.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/filelock')
-rw-r--r--dev-python/filelock/Manifest1
-rw-r--r--dev-python/filelock/filelock-3.16.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/filelock/Manifest b/dev-python/filelock/Manifest
index 869364d90493..70bb3897952e 100644
--- a/dev-python/filelock/Manifest
+++ b/dev-python/filelock/Manifest
@@ -1,2 +1,3 @@
DIST filelock-3.15.4.tar.gz 18007 BLAKE2B bf64d43b189453c8c1fcf258edefb2df340d20578d942d147197423c433cd6629d5e73615201d7ef84857450d7a4cf1375d0dfc69a422c4319a76f2dc157442f SHA512 d809df84f321ab9d99f46609cc664af2d9b73161906308e1a9f949c745694577901def228c40a860c606d652f9ecefe9014159eeea92266f94e981eecc4fe103
DIST filelock-3.16.0.tar.gz 18008 BLAKE2B 076880fb7c3db622b8391a89dd9bf85acaeec39abe7f189c65dfc72d6a6742727c9fd3cac727f397097e9688d9fc1c21a0e28334689db92091b66454c312464a SHA512 bda22692d3a6b034a825fff6917b0c12614ef2615ff52fd78072b1c76c1d1e6019d9d503faa0edf54efc39566279a941b19f34e9e87ccabb7fc8fadb1b3aa825
+DIST filelock-3.16.1.tar.gz 18037 BLAKE2B 29340ea0b5ade185a0d402a5cae304a2b3588d03ae543be26ed70b79bd1d0af67a30368ba43d87e16ac42d01b83ed1852316aaff87c11fe115ac35393a258231 SHA512 d935a01de58d219968795fa97a3ed9330285786fced2fde4474b3426cfc3da97c5b7a44a21c1f41185c1ce6a2a71514d259e990dce255be6b53e644449d575eb
diff --git a/dev-python/filelock/filelock-3.16.1.ebuild b/dev-python/filelock/filelock-3.16.1.ebuild
new file mode 100644
index 000000000000..8312a00e020a
--- /dev/null
+++ b/dev-python/filelock/filelock-3.16.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2018-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A platform independent file lock for Python"
+HOMEPAGE="
+ https://github.com/tox-dev/filelock/
+ https://pypi.org/project/filelock/
+"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest