summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-06 08:33:02 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-06 08:35:09 +0200
commitc319d34de7bc3afee05c1589ce0a842a5a9383e6 (patch)
tree04813295846a77fa7177a022a607c825223e2e06 /dev-python/flake8
parentdev-python/PyQt-builder: Remove old (diff)
downloadgentoo-c319d34de7bc3afee05c1589ce0a842a5a9383e6.tar.gz
gentoo-c319d34de7bc3afee05c1589ce0a842a5a9383e6.tar.bz2
gentoo-c319d34de7bc3afee05c1589ce0a842a5a9383e6.zip
dev-python/flake8: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flake8')
-rw-r--r--dev-python/flake8/Manifest1
-rw-r--r--dev-python/flake8/flake8-7.0.0.ebuild63
2 files changed, 0 insertions, 64 deletions
diff --git a/dev-python/flake8/Manifest b/dev-python/flake8/Manifest
index 340fa3fdfb18..0cf8d7634cc2 100644
--- a/dev-python/flake8/Manifest
+++ b/dev-python/flake8/Manifest
@@ -1,2 +1 @@
-DIST flake8-7.0.0.gh.tar.gz 138456 BLAKE2B faf0b54ede3c3184e12986fb9247f73a149a5fd9ebba90578aae8550d2749bcacdab1fa4699ea0b8d69309d0bd5c26dd5162c54a8f8eb33ed64009c919e147fe SHA512 cebcd61d266c6d2f837178d0708217b471662e81dabaa911850883657307747180173c5f6cde11abc2b14381baecff9d6adeca2979bcb85be03a4a6ff57de2c4
DIST flake8-7.1.0.gh.tar.gz 138600 BLAKE2B df6781e676d4eccf296d5fc3d767643956799d1c99adccb32d0005951f0aca13b7e99ff7506f7026e9ed6c2dd78d5bdd02d9a25aaf64a1353097b8a9c02c5739 SHA512 0e970bdb0facff3a6e2ee33a74fe77ee1f7c80fbc517125df34d831ff897e222d0955d56fa9e9eedef83ccdc4e92aa7bbc583517d7b19a8cf1041790a225693a
diff --git a/dev-python/flake8/flake8-7.0.0.ebuild b/dev-python/flake8/flake8-7.0.0.ebuild
deleted file mode 100644
index 3e197d89525d..000000000000
--- a/dev-python/flake8/flake8-7.0.0.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
-HOMEPAGE="
- https://github.com/PyCQA/flake8/
- https://pypi.org/project/flake8/
-"
-SRC_URI="
- https://github.com/PyCQA/flake8/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- <dev-python/pyflakes-3.3.0[${PYTHON_USEDEP}]
- >=dev-python/pyflakes-3.2.0[${PYTHON_USEDEP}]
- <dev-python/pycodestyle-2.12.0[${PYTHON_USEDEP}]
- >=dev-python/pycodestyle-2.11.0[${PYTHON_USEDEP}]
-"
-PDEPEND="
- >=dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
- <dev-python/mccabe-0.8.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- ${RDEPEND}
- test? (
- ${PDEPEND}
- )
-"
-
-distutils_enable_sphinx docs/source \
- dev-python/sphinx-prompt \
- dev-python/sphinx-rtd-theme
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # fails if additional flake8 plugins are installed
- tests/integration/test_plugins.py::test_local_plugin_can_add_option
- )
- if [[ ${EPYTHON} == pypy3 ]]; then
- EPYTEST_DESELECT+=(
- # problem with pypy3.10 in dev-python/pyflakes
- # https://github.com/PyCQA/pyflakes/issues/779
- tests/integration/test_main.py::test_malformed_per_file_ignores_error
- tests/integration/test_main.py::test_tokenization_error_but_not_syntax_error
- tests/integration/test_main.py::test_tokenization_error_is_a_syntax_error
- )
- fi
-
- epytest
-}