summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-05 06:30:35 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-05 06:30:35 +0200
commit24ca8dd8340fa694bf2b85d11d15f0ff191204c9 (patch)
tree7a55125104e33b3e649d14d92fee7f23f29655b8 /dev-python/flask-cors
parentdev-python/pywlroots: Bump to 0.16.8 (diff)
downloadgentoo-24ca8dd8340fa694bf2b85d11d15f0ff191204c9.tar.gz
gentoo-24ca8dd8340fa694bf2b85d11d15f0ff191204c9.tar.bz2
gentoo-24ca8dd8340fa694bf2b85d11d15f0ff191204c9.zip
dev-python/flask-cors: Bump to 4.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-cors')
-rw-r--r--dev-python/flask-cors/Manifest1
-rw-r--r--dev-python/flask-cors/flask-cors-4.0.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/flask-cors/Manifest b/dev-python/flask-cors/Manifest
index c5791930cf13..44ae3f08635e 100644
--- a/dev-python/flask-cors/Manifest
+++ b/dev-python/flask-cors/Manifest
@@ -1 +1,2 @@
DIST flask-cors-4.0.0.gh.tar.gz 31586 BLAKE2B ac3713a08108a621fb0150039a2c40b87a3331084223ec73fb6cf76444e4a7681350a01f18f507b0ee942f01731c289e44950d99412373e7c889beaffa116513 SHA512 04f163d646d2f5fc96b397a3d52ad0e6b99ae6caaec67855e05b4330a323d1b28ab4d624000cbce9a897dba8a00317828e7056537454d1bb7febfcdddd37096d
+DIST flask-cors-4.0.1.gh.tar.gz 32226 BLAKE2B f6301842b20175587be43d3c1f22fb341463f25d21fcae9b6463e8c48b149ab7ddf000d5541645f217755bc43863ef060cf1e2f6e57941632db420efb1cd223e SHA512 51dd7c50d5db6a6b6985a32f08f9512603e64199bf90dd22349cd1dbff94f1706b1e26cbe7765fb6dc6310fce86ac470896b127dc83cc740436e1ae11c11f7eb
diff --git a/dev-python/flask-cors/flask-cors-4.0.1.ebuild b/dev-python/flask-cors/flask-cors-4.0.1.ebuild
new file mode 100644
index 000000000000..9624e2a08270
--- /dev/null
+++ b/dev-python/flask-cors/flask-cors-4.0.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/corydolphin/flask-cors.git"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/corydolphin/flask-cors/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="A Flask extension for Cross Origin Resource Sharing (CORS)"
+HOMEPAGE="
+ https://github.com/corydolphin/flask-cors/
+ https://pypi.org/project/Flask-Cors/
+"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/flask[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme \
+ dev-python/sphinxcontrib-httpdomain