summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2019-11-17 12:47:01 -0500
committerAaron W. Swenson <titanofold@gentoo.org>2019-11-17 12:47:06 -0500
commit14aef7bfb944e8af61e7bc9828afe7ac95515232 (patch)
treefc7f34776bb8b4067ba1366d609b1a66ee68aed5 /dev-python/flask-htmlmin/flask-htmlmin-1.5.2.ebuild
parentnet-misc/gerbera: Version bump (diff)
downloadgentoo-14aef7bfb944e8af61e7bc9828afe7ac95515232.tar.gz
gentoo-14aef7bfb944e8af61e7bc9828afe7ac95515232.tar.bz2
gentoo-14aef7bfb944e8af61e7bc9828afe7ac95515232.zip
dev-python/flask-htmlmin: Bump to 1.5.2
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-python/flask-htmlmin/flask-htmlmin-1.5.2.ebuild')
-rw-r--r--dev-python/flask-htmlmin/flask-htmlmin-1.5.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/flask-htmlmin/flask-htmlmin-1.5.2.ebuild b/dev-python/flask-htmlmin/flask-htmlmin-1.5.2.ebuild
new file mode 100644
index 000000000000..7d47d05704ac
--- /dev/null
+++ b/dev-python/flask-htmlmin/flask-htmlmin-1.5.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+MY_PN="Flask-HTMLmin"
+MY_P=${MY_PN}-${PV}
+
+inherit distutils-r1
+
+DESCRIPTION="Minimize your flask rendered html"
+HOMEPAGE="https://github.com/hamidfzm/Flask-HTMLmin"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-text/htmlmin
+ dev-python/flask
+"
+
+DEPEND="${RDEPEND}
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_P}"
+
+# Needs some kind of magic to actually test.
+RESTRICT="test"