summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-21 21:18:43 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-21 21:22:47 +0200
commit463147078c6a10bbdaae3608209d2ca258a812b8 (patch)
treefc9e6e354bc21cd80df8469a8d24be480b4f393c /dev-python/flask-security
parentdev-python/astroid: Remove old (diff)
downloadgentoo-463147078c6a10bbdaae3608209d2ca258a812b8.tar.gz
gentoo-463147078c6a10bbdaae3608209d2ca258a812b8.tar.bz2
gentoo-463147078c6a10bbdaae3608209d2ca258a812b8.zip
dev-python/flask-security: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-security')
-rw-r--r--dev-python/flask-security/Manifest2
-rw-r--r--dev-python/flask-security/files/flask-security-3.4.3-optional-deps.patch63
-rw-r--r--dev-python/flask-security/flask-security-3.4.5.ebuild70
-rw-r--r--dev-python/flask-security/flask-security-4.1.3.ebuild66
4 files changed, 0 insertions, 201 deletions
diff --git a/dev-python/flask-security/Manifest b/dev-python/flask-security/Manifest
index 8eee8e2441c8..07841efb0a27 100644
--- a/dev-python/flask-security/Manifest
+++ b/dev-python/flask-security/Manifest
@@ -1,3 +1 @@
-DIST flask-security-3.4.5.gh.tar.gz 348928 BLAKE2B 9890227e9775c4a28fc364affb0bf767407463d514f6dc3cd359dd8a026e8325d943a547f294f6363a276f9e7d97336c526dd45f4549c7cfaff2d6ef9ef0316a SHA512 f9ac7f46b2e1ab7dbb44ba925b01e16304e8f8d6d5d56f4e558d07b80dfffa59f04c2597e17c00a7d7ae11be3a97c78ccf8d79993b7451be4a7f75f85bc89f6f
-DIST flask-security-4.1.3.gh.tar.gz 408609 BLAKE2B ef4b270d62de75fdcf51d1247960df85deca1699fdbfb73592a5711f9bb56f71a2f2de12a8d8c0eccdaccfef11a578cf9bd9abbf52bdacfe4bfc10f9adda0acc SHA512 92a0e7fce95eb4eb04baa9a11ee88ab3b8e88952aa6300bf8245cecfcc90657c83bbe93e1c3b19d62642a346b30f5912dd424e59a81023637f3183a61e8cf91c
DIST flask-security-4.1.4.gh.tar.gz 408532 BLAKE2B 5fd401da8a907ff56ab7fe1fc79ec586222c26d60d921534afea4743cbc6840098f8a1d231741f83f061e2a4f747c4937be848aa4bfee8b3cf4bc06a8928e437 SHA512 d9ec87d1d2baa11b00db437135060630ea06451d96057fc8712ced8bc433fb6779f7b2561ad1c96d8f192a43acdc93dddf7f44ec75f89297204fd1796dcad1df
diff --git a/dev-python/flask-security/files/flask-security-3.4.3-optional-deps.patch b/dev-python/flask-security/files/flask-security-3.4.3-optional-deps.patch
deleted file mode 100644
index 484e816908f4..000000000000
--- a/dev-python/flask-security/files/flask-security-3.4.3-optional-deps.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-From 8943f49c3e6064839bd1e3c2c73a750b2b476ae3 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Wed, 15 Jul 2020 09:02:15 +0200
-Subject: [PATCH 1/2] tests: Skip tests requiring specific data backends if not
- available
-
-Skip tests that require a specific database backend if the respective
-package is not available. This is mostly intended to make it possible
-to test flask-security on Python 3.9 since Pony does not support this
-Python version but there is no harm in extending it to other backends.
-
-Technically, Flask-SQLAlchemy is still required due to other tests.
----
- tests/conftest.py | 5 +++++
- 1 file changed, 5 insertions(+)
-
-diff --git a/tests/conftest.py b/tests/conftest.py
-index 3305d92..a48f480 100644
---- a/tests/conftest.py
-+++ b/tests/conftest.py
-@@ -218,6 +218,7 @@ def mongoengine_datastore(request, app, tmpdir, realdburl):
-
-
- def mongoengine_setup(request, app, tmpdir, realdburl):
-+ pytest.importorskip('flask_mongoengine')
- from flask_mongoengine import MongoEngine
- from mongoengine.fields import (
- BooleanField,
-@@ -282,6 +283,7 @@ def sqlalchemy_datastore(request, app, tmpdir, realdburl):
-
-
- def sqlalchemy_setup(request, app, tmpdir, realdburl):
-+ pytest.importorskip('flask_sqlalchemy')
- from flask_sqlalchemy import SQLAlchemy
- from flask_security.models import fsqla_v2 as fsqla
-
-@@ -326,6 +328,7 @@ def sqlalchemy_session_datastore(request, app, tmpdir, realdburl):
-
-
- def sqlalchemy_session_setup(request, app, tmpdir, realdburl):
-+ pytest.importorskip('sqlalchemy')
- from sqlalchemy import create_engine
- from sqlalchemy.orm import scoped_session, sessionmaker, relationship, backref
- from sqlalchemy.ext.declarative import declarative_base
-@@ -426,6 +429,7 @@ def peewee_datastore(request, app, tmpdir, realdburl):
-
-
- def peewee_setup(request, app, tmpdir, realdburl):
-+ pytest.importorskip('peewee')
- from peewee import (
- TextField,
- DateTimeField,
-@@ -522,6 +526,7 @@ def pony_datastore(request, app, tmpdir, realdburl):
-
- def pony_setup(request, app, tmpdir, realdburl):
-
-+ pytest.importorskip('pony')
- from pony.orm import Database, Optional, Required, Set
- from pony.orm.core import SetInstance
-
---
-2.27.0
-
diff --git a/dev-python/flask-security/flask-security-3.4.5.ebuild b/dev-python/flask-security/flask-security-3.4.5.ebuild
deleted file mode 100644
index 29569ae89496..000000000000
--- a/dev-python/flask-security/flask-security-3.4.5.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-inherit distutils-r1
-
-DESCRIPTION="Simple security for Flask apps"
-HOMEPAGE="
- https://github.com/Flask-Middleware/flask-security/
- https://pypi.org/project/Flask-Security-Too/"
-SRC_URI="
- https://github.com/Flask-Middleware/flask-security/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="
- dev-python/cachetools[${PYTHON_USEDEP}]
- >=dev-python/flask-1.1.1[${PYTHON_USEDEP}]
- >=dev-python/flask-babelex-0.9.3[${PYTHON_USEDEP}]
- >=dev-python/flask-login-0.4.1[${PYTHON_USEDEP}]
- >=dev-python/flask-principal-0.4.0[${PYTHON_USEDEP}]
- >=dev-python/flask-wtf-0.14.2[${PYTHON_USEDEP}]
- >=dev-python/itsdangerous-1.1.0[${PYTHON_USEDEP}]
- >=dev-python/passlib-1.7.2[${PYTHON_USEDEP}]
- >=dev-python/python-email-validator-1.0.5[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- dev-python/Babel[${PYTHON_USEDEP}]
- test? (
- >=dev-python/argon2-cffi-19.1.0[${PYTHON_USEDEP}]
- >=dev-python/bcrypt-3.1.5[${PYTHON_USEDEP}]
- >=dev-python/cryptography-2.3.1[${PYTHON_USEDEP}]
- >=dev-python/flask-mail-0.9.1[${PYTHON_USEDEP}]
- >=dev-python/flask-sqlalchemy-2.3[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- >=dev-python/mongomock-3.19.0[${PYTHON_USEDEP}]
- >=dev-python/peewee-3.11.2[${PYTHON_USEDEP}]
- >=dev-python/phonenumbers-8.11.1[${PYTHON_USEDEP}]
- >=dev-python/psycopg-2.8.4:2[${PYTHON_USEDEP}]
- >=dev-python/pymysql-0.9.3[${PYTHON_USEDEP}]
- >=dev-python/pyqrcode-1.2[${PYTHON_USEDEP}]
- >=dev-python/zxcvbn-4.4.28[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.4.3-optional-deps.patch
-)
-
-src_prepare() {
- sed -i -e '/setup_requires/d' setup.py || die
- sed -e 's@--cov flask_security@-p no:httpbin@' \
- -e 's:--cov-report term-missing::' \
- -e 's:--black::' \
- -e 's:--flake8::' \
- -e 's:--cache-clear::' \
- -i pytest.ini || die
- distutils-r1_src_prepare
-}
-
-python_configure_all() {
- esetup.py compile_catalog
-}
diff --git a/dev-python/flask-security/flask-security-4.1.3.ebuild b/dev-python/flask-security/flask-security-4.1.3.ebuild
deleted file mode 100644
index 80cde17b13c7..000000000000
--- a/dev-python/flask-security/flask-security-4.1.3.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Simple security for Flask apps"
-HOMEPAGE="
- https://github.com/Flask-Middleware/flask-security/
- https://pypi.org/project/Flask-Security-Too/"
-SRC_URI="
- https://github.com/Flask-Middleware/flask-security/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~riscv x86"
-
-RDEPEND="
- >=dev-python/bleach-3.3.1[${PYTHON_USEDEP}]
- >=dev-python/blinker-1.4[${PYTHON_USEDEP}]
- dev-python/cachetools[${PYTHON_USEDEP}]
- >=dev-python/flask-1.1.1[${PYTHON_USEDEP}]
- >=dev-python/flask-babelex-0.9.3[${PYTHON_USEDEP}]
- >=dev-python/flask-login-0.4.1[${PYTHON_USEDEP}]
- >=dev-python/flask-principal-0.4.0[${PYTHON_USEDEP}]
- >=dev-python/flask-wtf-0.14.3[${PYTHON_USEDEP}]
- >=dev-python/itsdangerous-1.1.0[${PYTHON_USEDEP}]
- >=dev-python/passlib-1.7.2[${PYTHON_USEDEP}]
- >=dev-python/python-email-validator-1.1.1[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- dev-python/Babel[${PYTHON_USEDEP}]
- test? (
- >=dev-python/argon2-cffi-19.1.0[${PYTHON_USEDEP}]
- >=dev-python/bcrypt-3.1.5[${PYTHON_USEDEP}]
- dev-python/bleach[${PYTHON_USEDEP}]
- >=dev-python/cryptography-2.3.1[${PYTHON_USEDEP}]
- >=dev-python/flask-mail-0.9.1[${PYTHON_USEDEP}]
- >=dev-python/flask-sqlalchemy-2.3[${PYTHON_USEDEP}]
- >=dev-python/mongomock-3.19.0[${PYTHON_USEDEP}]
- >=dev-python/peewee-3.11.2[${PYTHON_USEDEP}]
- >=dev-python/phonenumbers-8.11.1[${PYTHON_USEDEP}]
- >=dev-python/psycopg-2.8.4:2[${PYTHON_USEDEP}]
- >=dev-python/pymysql-0.9.3[${PYTHON_USEDEP}]
- >=dev-python/pyqrcode-1.2[${PYTHON_USEDEP}]
- >=dev-python/zxcvbn-4.4.28[${PYTHON_USEDEP}]
- >=dev-python/pony-0.7.11[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -i -e 's@--cache-clear@-p no:httpbin@' pytest.ini || die
- distutils-r1_src_prepare
-}
-
-python_configure_all() {
- esetup.py compile_catalog
-}