summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-17 10:07:43 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-17 11:10:17 +0300
commit148dec3b0bb0ea00ad480999bf30574f2e42b3e7 (patch)
treeb0628260fded011e74f774e3ec4114da5d8448b9 /dev-python/flask-sphinx-themes
parentdev-python/blessed: enable py3.11 (diff)
downloadgentoo-148dec3b0bb0ea00ad480999bf30574f2e42b3e7.tar.gz
gentoo-148dec3b0bb0ea00ad480999bf30574f2e42b3e7.tar.bz2
gentoo-148dec3b0bb0ea00ad480999bf30574f2e42b3e7.zip
dev-python/*: EAPI=8, PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/flask-sphinx-themes')
-rw-r--r--dev-python/flask-sphinx-themes/flask-sphinx-themes-1.0.2-r1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/flask-sphinx-themes/flask-sphinx-themes-1.0.2-r1.ebuild b/dev-python/flask-sphinx-themes/flask-sphinx-themes-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..9a879c444778
--- /dev/null
+++ b/dev-python/flask-sphinx-themes/flask-sphinx-themes-1.0.2-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="Flask-Sphinx-Themes"
+MY_P="${MY_PN}-${PV}"
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Sphinx Themes for Flask related projects and Flask itself"
+HOMEPAGE="https://github.com/pallets/flask-sphinx-themes https://pypi.org/project/Flask-Sphinx-Themes/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"