summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-04 07:56:50 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-04 07:56:50 +0100
commit7a8a50a920e103c66621053731deb53ab187b2cd (patch)
tree014fd5fbab90566bddb6adc0942516ff652405d1 /dev-python/fonttools
parentapp-admin/awscli: Bump to 1.36.15 (diff)
downloadgentoo-7a8a50a920e103c66621053731deb53ab187b2cd.tar.gz
gentoo-7a8a50a920e103c66621053731deb53ab187b2cd.tar.bz2
gentoo-7a8a50a920e103c66621053731deb53ab187b2cd.zip
dev-python/fonttools: Bump to 4.55.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fonttools')
-rw-r--r--dev-python/fonttools/Manifest1
-rw-r--r--dev-python/fonttools/fonttools-4.55.1.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/dev-python/fonttools/Manifest b/dev-python/fonttools/Manifest
index d9ebbb2f3e32..3b48139682cf 100644
--- a/dev-python/fonttools/Manifest
+++ b/dev-python/fonttools/Manifest
@@ -3,3 +3,4 @@ DIST fonttools-4.53.1.gh.tar.gz 3850978 BLAKE2B 9c6b5af2cbde939b82043e29ffbbb234
DIST fonttools-4.54.0.gh.tar.gz 3858868 BLAKE2B edd02f52d094223e4217a85cab10c7c384977cf7a57abaab401b73c8a0fc638b4e23fa44f7f3a728824bc67888ebb7136a3bdce08efe99434d0b07347fc188b6 SHA512 0840c8fbcabd5555c2226bb89cba306e5b792c4ed92063f7c32c26616d9e4b061ae782177a1181a9e891a686ca6265796e50ed7c0acf8c82051697a8618f7623
DIST fonttools-4.54.1.gh.tar.gz 3863311 BLAKE2B 879edb1d5639b2d5a40d10531209504bf30912804a482be16071673727f693042e3158c65b02dc290bfad91767d3f4df10c62539b400f1d48253acf5bf2b86be SHA512 07e5d2401979fa7b1f926a3e3dfb05c2d712e9056e5bd49f879ed818d1f0ec1eb2435b295e30cd95a4e57288e2ce1c113c96a98093b4b57843bb6e3c9d07a7ad
DIST fonttools-4.55.0.gh.tar.gz 3886815 BLAKE2B ace8c3c1c866f4c181f685a44aeb69b8927bd7ddd452cb8268dc7c06183b372ddd88b64f7eba7ab3e4fa15ae359ffcf1d8144de4afbb1b4751173d75259eef3b SHA512 5f8a65687b5d66604eff5c518aaa51e5b2307e624e5397e5dc15b9489eeb6f300376ab6c70288f9bb7056532951f16085c5580f03b44de2a1d53f2860b573191
+DIST fonttools-4.55.1.gh.tar.gz 3888082 BLAKE2B 01cc804ad04814dbb397000e7c408e0994dce5c33c8f1a43b570258b27b9981f437d0469bdcbdf22eb3ee101fc6c17f8a1ab064e11a1bf471f6e3f2957056010 SHA512 68bab5b76b2dda4ebb306764434248020ee0750e4ab700ebb0db6c78b832dd87d58ee12c51b2b54da13027ea0a109460e6ed68eb0afebd5fbe51fb6d2ce7e7ff
diff --git a/dev-python/fonttools/fonttools-4.55.1.ebuild b/dev-python/fonttools/fonttools-4.55.1.ebuild
new file mode 100644
index 000000000000..80efba1ec9e3
--- /dev/null
+++ b/dev-python/fonttools/fonttools-4.55.1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="
+ https://github.com/fonttools/fonttools/
+ https://pypi.org/project/fonttools/
+"
+SRC_URI="
+ https://github.com/fonttools/fonttools/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="+native-extensions"
+
+RDEPEND="
+ >=dev-python/fs-2.4.9[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ native-extensions? (
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+ test? (
+ dev-python/brotlicffi[${PYTHON_USEDEP}]
+ dev-python/munkres[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ app-arch/zopfli
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # When dev-python/pytest-shutil is installed, we get weird import errors.
+ # This is due to incomplete nesting in the Tests/ tree:
+ #
+ # Tests/feaLib/__init__.py
+ # Tests/ufoLib/__init__.py
+ # Tests/svgLib/path/__init__.py
+ # Tests/otlLib/__init__.py
+ # Tests/varLib/__init__.py
+ #
+ # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
+ touch Tests/svgLib/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ local -x FONTTOOLS_WITH_CYTHON=$(usex native-extensions)
+ [[ ${EPYTHON} == pypy3 ]] && FONTTOOLS_WITH_CYTHON=0
+ distutils-r1_python_compile
+}
+
+src_test() {
+ # virtualx used when matplotlib is installed causing plot module tests to run
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # flaky test
+ Tests/ttLib/woff2_test.py::WOFF2ReaderTest::test_get_normal_tables
+ )
+
+ if [[ ${EPYTHON} == pypy3 ]] &&
+ has_version "dev-python/pyxattr[${PYTHON_USEDEP}]" &&
+ {
+ has_version "<dev-python/pypy3_10-exe-7.3.13_p2" ||
+ has_version "<dev-python/pypy3_10-exe-bin-7.3.13_p2"
+ }
+ then
+ EPYTEST_DESELECT+=(
+ # affected by a bug in PyPy/pyxattr
+ # https://github.com/iustin/pyxattr/issues/41
+ Tests/t1Lib/t1Lib_test.py::ReadWriteTest::test_read_with_path
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ nonfatal epytest \
+ -p rerunfailures --reruns=5 \
+ Tests fontTools || die -n "Tests failed with ${EPYTHON}"
+}