summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-10 07:23:35 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-10 07:57:03 +0200
commita0a2b573b9b208ee8be6fe51096d0fb6cd81baaa (patch)
treeb9ad7c36dac8b44851401ed77876624d3a6a1822 /dev-python/fonttools
parentdev-python/nuitka: Bump to 0.6.16.3 (diff)
downloadgentoo-a0a2b573b9b208ee8be6fe51096d0fb6cd81baaa.tar.gz
gentoo-a0a2b573b9b208ee8be6fe51096d0fb6cd81baaa.tar.bz2
gentoo-a0a2b573b9b208ee8be6fe51096d0fb6cd81baaa.zip
dev-python/fonttools: Bump to 4.26.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fonttools')
-rw-r--r--dev-python/fonttools/Manifest1
-rw-r--r--dev-python/fonttools/fonttools-4.26.2.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/fonttools/Manifest b/dev-python/fonttools/Manifest
index d5b5afa2ea10..d91ea8ce5b56 100644
--- a/dev-python/fonttools/Manifest
+++ b/dev-python/fonttools/Manifest
@@ -1,2 +1,3 @@
DIST fonttools-4.24.4.tar.gz 2556059 BLAKE2B c415ae5214b6df7171a5f8a7ea179b1a4adbc6646598d773f0d3d6a8cd777e8fd3c74c14f00e6c4735a73e712e3fd42ddfc96f3f101d34b122fb9c471d4d94a3 SHA512 aa4ee8f0a7f9cb6d8a84497e6f33f891491cd06cc477a785715f8fde8e5b33cf781ef8b848bfab8cf9a97fc15c018d493c6baf0fb8fd314b8a348c36ff627f41
DIST fonttools-4.26.1.tar.gz 2579211 BLAKE2B 886a803f6214658423c98bd347db6e2cc0baea5e2619ce18ba2a96589785a1b93228f5b35dd7f6c819b81ca471d6ea1a09d12ad6de04c75388ab6cb5003f5bf5 SHA512 226338cd1c3f71662080c69b0786a6a945b5a75d3a4b7ee6fcf6d7e2e089407d11b4a43950c7aebdaeccad1819e5c6e0b947938fbfbaa3caa9747b7b4a1bd5f6
+DIST fonttools-4.26.2.tar.gz 2579391 BLAKE2B 35a2533a336498aa1d5b9c2a61c1de6af03e6a7a1932a1ad71522f7f73e52590c347fe3e7d60b93b013389023792e6e6b91d6b4bfb92e007062dc2ac494adbb6 SHA512 2caa52a48574e6bdf418fe57fb4ca69686eeae65cb1f44c0cb16c64400ea666530dfcca9e8a619859cf553435f93b38f63e422c315206ecec467eed6339a5987
diff --git a/dev-python/fonttools/fonttools-4.26.2.ebuild b/dev-python/fonttools/fonttools-4.26.2.ebuild
new file mode 100644
index 000000000000..925c4733a1ac
--- /dev/null
+++ b/dev-python/fonttools/fonttools-4.26.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="https://github.com/fonttools/fonttools/"
+SRC_URI="https://github.com/fonttools/fonttools/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+RDEPEND=">=dev-python/fs-2.4.9[${PYTHON_USEDEP}]"
+BDEPEND="
+ ${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ app-arch/zopfli
+ )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # When dev-python/pytest-shutil is installed, we get weird import errors.
+ # This is due to incomplete nesting in the Tests/ tree:
+ #
+ # Tests/feaLib/__init__.py
+ # Tests/ufoLib/__init__.py
+ # Tests/svgLib/path/__init__.py
+ # Tests/otlLib/__init__.py
+ # Tests/varLib/__init__.py
+ #
+ # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
+ touch Tests/svgLib/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_configure() {
+ DISTUTILS_ARGS=( --with-cython )
+}
+
+python_test() {
+ distutils_install_for_testing
+ # virtualx used when matplotlib is installed causing plot module tests to run
+ virtx epytest Tests fontTools
+}