summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-11 07:15:04 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-11 07:47:28 +0100
commite1d0b81d2e8d4be0ff8cb389b64e90d912540f5c (patch)
treee9829c7835fdde507aecc24b9a13dc9f2d7f65b7 /dev-python/fonttools
parentapp-crypt/cfssl: rename mkbundle to mkbundle.cfssl (diff)
downloadgentoo-e1d0b81d2e8d4be0ff8cb389b64e90d912540f5c.tar.gz
gentoo-e1d0b81d2e8d4be0ff8cb389b64e90d912540f5c.tar.bz2
gentoo-e1d0b81d2e8d4be0ff8cb389b64e90d912540f5c.zip
dev-python/fonttools: Bump to 4.55.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fonttools')
-rw-r--r--dev-python/fonttools/Manifest1
-rw-r--r--dev-python/fonttools/fonttools-4.55.3.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/dev-python/fonttools/Manifest b/dev-python/fonttools/Manifest
index 55cf976b43fa..65301f5481b0 100644
--- a/dev-python/fonttools/Manifest
+++ b/dev-python/fonttools/Manifest
@@ -5,3 +5,4 @@ DIST fonttools-4.54.1.gh.tar.gz 3863311 BLAKE2B 879edb1d5639b2d5a40d10531209504b
DIST fonttools-4.55.0.gh.tar.gz 3886815 BLAKE2B ace8c3c1c866f4c181f685a44aeb69b8927bd7ddd452cb8268dc7c06183b372ddd88b64f7eba7ab3e4fa15ae359ffcf1d8144de4afbb1b4751173d75259eef3b SHA512 5f8a65687b5d66604eff5c518aaa51e5b2307e624e5397e5dc15b9489eeb6f300376ab6c70288f9bb7056532951f16085c5580f03b44de2a1d53f2860b573191
DIST fonttools-4.55.1.gh.tar.gz 3888082 BLAKE2B 01cc804ad04814dbb397000e7c408e0994dce5c33c8f1a43b570258b27b9981f437d0469bdcbdf22eb3ee101fc6c17f8a1ab064e11a1bf471f6e3f2957056010 SHA512 68bab5b76b2dda4ebb306764434248020ee0750e4ab700ebb0db6c78b832dd87d58ee12c51b2b54da13027ea0a109460e6ed68eb0afebd5fbe51fb6d2ce7e7ff
DIST fonttools-4.55.2.gh.tar.gz 3887441 BLAKE2B 1918b07de8513f1645e1ceb1fe1273bbdbc6ac9d52da69ca36c3872f74f17c7632b67879dc64d4d248f05422434407837a5117c29257414f348e47f137fe378d SHA512 c379300766161b00d834b2abd910162a83e89e8b2609997c227192d1b38c414a4fe0f36f75ce8b1f418dc9443394d64cfdc67f370c3debe96e9e53b6cc68dfb4
+DIST fonttools-4.55.3.gh.tar.gz 3894793 BLAKE2B 0b02f5d5cac5b7cdd97d4c32310d02507604afbef12ecd59237fb0a5683170bd563f8e5c08f4f2ca057a8f952aafef7c6e087d072d96786ef8bea603521ce4ab SHA512 23257ebb9e890c0e5eb9776a9e82479a33859f4ab49015ee8434ae998814b7821b5226d14405667f9c67f03bbd0db41087d95dbc7650d812ed826db71929cab3
diff --git a/dev-python/fonttools/fonttools-4.55.3.ebuild b/dev-python/fonttools/fonttools-4.55.3.ebuild
new file mode 100644
index 000000000000..80efba1ec9e3
--- /dev/null
+++ b/dev-python/fonttools/fonttools-4.55.3.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="
+ https://github.com/fonttools/fonttools/
+ https://pypi.org/project/fonttools/
+"
+SRC_URI="
+ https://github.com/fonttools/fonttools/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="+native-extensions"
+
+RDEPEND="
+ >=dev-python/fs-2.4.9[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ native-extensions? (
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+ test? (
+ dev-python/brotlicffi[${PYTHON_USEDEP}]
+ dev-python/munkres[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ app-arch/zopfli
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # When dev-python/pytest-shutil is installed, we get weird import errors.
+ # This is due to incomplete nesting in the Tests/ tree:
+ #
+ # Tests/feaLib/__init__.py
+ # Tests/ufoLib/__init__.py
+ # Tests/svgLib/path/__init__.py
+ # Tests/otlLib/__init__.py
+ # Tests/varLib/__init__.py
+ #
+ # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
+ touch Tests/svgLib/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ local -x FONTTOOLS_WITH_CYTHON=$(usex native-extensions)
+ [[ ${EPYTHON} == pypy3 ]] && FONTTOOLS_WITH_CYTHON=0
+ distutils-r1_python_compile
+}
+
+src_test() {
+ # virtualx used when matplotlib is installed causing plot module tests to run
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # flaky test
+ Tests/ttLib/woff2_test.py::WOFF2ReaderTest::test_get_normal_tables
+ )
+
+ if [[ ${EPYTHON} == pypy3 ]] &&
+ has_version "dev-python/pyxattr[${PYTHON_USEDEP}]" &&
+ {
+ has_version "<dev-python/pypy3_10-exe-7.3.13_p2" ||
+ has_version "<dev-python/pypy3_10-exe-bin-7.3.13_p2"
+ }
+ then
+ EPYTEST_DESELECT+=(
+ # affected by a bug in PyPy/pyxattr
+ # https://github.com/iustin/pyxattr/issues/41
+ Tests/t1Lib/t1Lib_test.py::ReadWriteTest::test_read_with_path
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ nonfatal epytest \
+ -p rerunfailures --reruns=5 \
+ Tests fontTools || die -n "Tests failed with ${EPYTHON}"
+}