summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-12 18:42:08 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-12 18:52:20 +0200
commit33e8ed864fce654ee05fa02af83928fbffe88b47 (patch)
tree5f786b8a357eb6cb5a8db602ede4dd9e34984890 /dev-python/fs
parentdev-python/flask-wtf: Remove redundant versions (diff)
downloadgentoo-33e8ed864fce654ee05fa02af83928fbffe88b47.tar.gz
gentoo-33e8ed864fce654ee05fa02af83928fbffe88b47.tar.bz2
gentoo-33e8ed864fce654ee05fa02af83928fbffe88b47.zip
dev-python/fs: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fs')
-rw-r--r--dev-python/fs/fs-2.4.9.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/fs/fs-2.4.9.ebuild b/dev-python/fs/fs-2.4.9.ebuild
deleted file mode 100644
index a68ebf6c8e9f..000000000000
--- a/dev-python/fs/fs-2.4.9.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="Filesystem abstraction layer"
-HOMEPAGE="
- https://pypi.org/project/fs/
- https://docs.pyfilesystem.org
- https://www.willmcgugan.com/tag/fs/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/appdirs-1.4.3[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- >=dev-python/six-1.10[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-BDEPEND="test? (
- $(python_gen_cond_dep '
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pyftpdlib[${PYTHON_USEDEP}]
- dev-python/pysendfile[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
- ' -3)
-)"
-
-python_test() {
- # python2_7 tests require dev-python/typing which is
- # now in stdlib so ignore tests. py2.7 is going away.
- if python_is_python3; then
- esetup.py test || die "tests failed"
- fi
-}
-
-pkg_postinst() {
- optfeature "S3 support" dev-python/boto
- optfeature "SFTP support" dev-python/paramiko
- optfeature "Browser support" dev-python/wxpython
-}