summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-21 06:44:34 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-21 06:55:25 +0200
commita4671ceedb8bc359e351231593653cc9fe10550b (patch)
tree35c2fef474097f5a1e4070c635c4281e6697fd3e /dev-python/furo
parentdev-python/requests-unixsocket: Fix urllib3-2.0* compatibility (diff)
downloadgentoo-a4671ceedb8bc359e351231593653cc9fe10550b.tar.gz
gentoo-a4671ceedb8bc359e351231593653cc9fe10550b.tar.bz2
gentoo-a4671ceedb8bc359e351231593653cc9fe10550b.zip
dev-python/furo: Bump to 2023.5.20
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/furo')
-rw-r--r--dev-python/furo/Manifest1
-rw-r--r--dev-python/furo/furo-2023.5.20.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/furo/Manifest b/dev-python/furo/Manifest
index fb0af9d2a4ce..69e58ab5634f 100644
--- a/dev-python/furo/Manifest
+++ b/dev-python/furo/Manifest
@@ -1 +1,2 @@
DIST furo-2023.3.27-py3-none-any.whl 327605 BLAKE2B 1368aabdbd497acf181c5b059da6d4bd3ae11e66bb81ec097358e051f7c64b7cffa537d5855ed68293398b26bb7df4d35a183c3eea00d4790b786b0f4bdbc6eb SHA512 7d321f59064d64c205c9c1a207fd62685c22102bc1546f0e063be9565458c6eed887e9f52851160e2658401ac8ed791572183e3c067c2e85c9c1811411e051f6
+DIST furo-2023.5.20-py3-none-any.whl 326767 BLAKE2B cc8eb3816bf99039e1a312f9fed21538b0154ece228e351107df89f5770c382614efc7202bae742d28d2fc8fceabc8b748b2bfbe8a230aeb70f280b622d42c11 SHA512 1a97b37aa9ce55878f34e3276eebeb4b138bd9e397b6711469fed4523ab8dadcd91e77234a1eca20561276f6660410a31f48f34ae320c6772d1055699cdd7125
diff --git a/dev-python/furo/furo-2023.5.20.ebuild b/dev-python/furo/furo-2023.5.20.ebuild
new file mode 100644
index 000000000000..0674aa0b847b
--- /dev/null
+++ b/dev-python/furo/furo-2023.5.20.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# sphinx-theme-builder is completely unusable, as it requires pinning
+# to a very-specific nodejs version number, and ofc loves fetching
+# everything from the Internet
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( pypy3 python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Clean customisable Sphinx documentation theme"
+HOMEPAGE="
+ https://pypi.org/project/furo/
+ https://github.com/pradyunsg/furo/
+"
+SRC_URI="$(pypi_wheel_url)"
+S=${WORKDIR}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-basic-ng[${PYTHON_USEDEP}]
+"
+
+python_compile() {
+ distutils_wheel_install "${BUILD_DIR}/install" \
+ "${DISTDIR}/${P}-py3-none-any.whl"
+}