summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-02-19 18:50:40 -0500
committerTim Harder <radhermit@gentoo.org>2018-03-01 14:34:44 -0500
commitb1e3204764b973996144bb3fcb92846d7fe5b38a (patch)
tree5ed4b3187a63b86e7aab1a7dc724d4b16e61e2db /dev-python/futures/futures-3.0.3.ebuild
parentdev-python/futures: stabilize 3.1.1 for arm64 (diff)
downloadgentoo-b1e3204764b973996144bb3fcb92846d7fe5b38a.tar.gz
gentoo-b1e3204764b973996144bb3fcb92846d7fe5b38a.tar.bz2
gentoo-b1e3204764b973996144bb3fcb92846d7fe5b38a.zip
dev-python/futures: remove old
Diffstat (limited to 'dev-python/futures/futures-3.0.3.ebuild')
-rw-r--r--dev-python/futures/futures-3.0.3.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/futures/futures-3.0.3.ebuild b/dev-python/futures/futures-3.0.3.ebuild
deleted file mode 100644
index b184442a9eb2..000000000000
--- a/dev-python/futures/futures-3.0.3.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 pypy )
-inherit distutils-r1
-
-DESCRIPTION="Backport of the concurrent.futures package from Python 3.2"
-HOMEPAGE="https://pypi.python.org/pypi/futures"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
-IUSE="doc"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- # tests that fail under pypy
- # https://code.google.com/p/pythonfutures/issues/detail?id=27
- if [[ "${EPYTHON}" == pypy ]]; then
- sed -e 's:test_del_shutdown:_&:g' \
- -e 's:test_repr:_&:' -i test_futures.py || die
- fi
- "${PYTHON}" test_futures.py || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- local DOCS=( CHANGES )
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}