summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-08-14 20:57:58 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-08-14 22:32:33 +0000
commitaed9fcf718bd2108558635b31d4f8d8fc0b29dfa (patch)
tree88549d305c15cfdb5d81f3b0078e9d3281407a1a /dev-python/girder-client
parentapp-i18n/ibus-libpinyin: version bump to 1.9.0. (diff)
downloadgentoo-aed9fcf718bd2108558635b31d4f8d8fc0b29dfa.tar.gz
gentoo-aed9fcf718bd2108558635b31d4f8d8fc0b29dfa.tar.bz2
gentoo-aed9fcf718bd2108558635b31d4f8d8fc0b29dfa.zip
dev-python/girder-client: initial import
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'dev-python/girder-client')
-rw-r--r--dev-python/girder-client/Manifest1
-rw-r--r--dev-python/girder-client/girder-client-2.3.0.ebuild29
-rw-r--r--dev-python/girder-client/metadata.xml15
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/girder-client/Manifest b/dev-python/girder-client/Manifest
new file mode 100644
index 000000000000..39f0b1670555
--- /dev/null
+++ b/dev-python/girder-client/Manifest
@@ -0,0 +1 @@
+DIST girder-client-2.3.0.tar.gz 19976 SHA256 8c336ccfa6f837d3967756444d59a049668d3ca0c5730d1bf82f9b39f2225cb2 SHA512 68bbb9aa328b9021b8d3604269df75f67c63631aebdad3b2268e8b170cc65ede911dc57abf049c091f033d85f7026c0869c68ceaed4ebf830f3f1d34d7e59fbb WHIRLPOOL a3b5ab088fa617fc77857e5669f4ba59dd7ac946b2fefae3551211ea2b0ca9c33989a0ef6a581c3bef5a836c4ab362f1ec6e5bf986107fad895a425b9f55673e
diff --git a/dev-python/girder-client/girder-client-2.3.0.ebuild b/dev-python/girder-client/girder-client-2.3.0.ebuild
new file mode 100644
index 000000000000..069b6e055e9c
--- /dev/null
+++ b/dev-python/girder-client/girder-client-2.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python libraries and CLI to interact with the REST API of a Girder server"
+HOMEPAGE="http://girder.readthedocs.org/en/latest/python-client.html"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+# see https://github.com/girder/girder/tree/master/clients/python
+RDEPEND="
+ >=dev-python/click-6.7[${PYTHON_USEDEP}]
+ >=dev-python/diskcache-1.6.7[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.10[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
diff --git a/dev-python/girder-client/metadata.xml b/dev-python/girder-client/metadata.xml
new file mode 100644
index 000000000000..eedb195e5a4d
--- /dev/null
+++ b/dev-python/girder-client/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Gentoo Python Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Set of python libraries and a command-line tool that can
+ be used to interact with the REST API of a Girder server.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">girder-client</remote-id>
+ </upstream>
+</pkgmetadata>