summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-22 10:12:23 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-22 10:19:10 +0200
commit1ef68c7b825266720eb89f3ee6026a5386d39a1c (patch)
tree88408f76b2c490ff5c5016a37cce5317c0c9e636 /dev-python/google-auth
parentdev-python/authheaders: Bump to 0.15.1 (diff)
downloadgentoo-1ef68c7b825266720eb89f3ee6026a5386d39a1c.tar.gz
gentoo-1ef68c7b825266720eb89f3ee6026a5386d39a1c.tar.bz2
gentoo-1ef68c7b825266720eb89f3ee6026a5386d39a1c.zip
dev-python/google-auth: Bump to 2.6.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest1
-rw-r--r--dev-python/google-auth/google-auth-2.6.6.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index 7134288f746c..6ca203cf9563 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,3 +1,4 @@
DIST google-auth-2.6.3.tar.gz 189685 BLAKE2B 68718ce4031c4e764dcfec19361b034ed5e1efa602d5c734b61a853020f40aaa856f9d9a3b964470e148fbfcb081dbc7d2c8bf0a53fc843d9360dbc72623bcdf SHA512 cba3228dbc0887c127d50cc45eb134e3a0b2bea044b8a1e65807918a3808e550fd58217a236c07b6cb908e5a080d9c1c1a2e9ee1853968d8c0bd50b7228ea262
DIST google-auth-2.6.4.tar.gz 189668 BLAKE2B fe1f660c80095bae4772c78e223f8ba2be1ee749f4571249236fee84abd9a165d08c1acb5dad4ee61accd86c5b60c66befb24c9cbc5665b95bc587dddf99ecb7 SHA512 616004ad945e88dd9561abfcb29c69a0ade5163d6175191bf9421a2d59620a042ae352d833fc20e5f31e20b929dda391a35aa2d391b17af221bc4044f82663f9
DIST google-auth-2.6.5.tar.gz 189699 BLAKE2B 2a18c25e13a48562aaa5d7524857343928f35ecec4a11a85e50f022acc6d2e90bc1e604c7ed1a4141ace4af830ceb466ef71e4678d7fbb5fb0fe9407d9de544d SHA512 f5b63b879348d86b7d840a188435c444e2b35dd3e7421c284092bfd9421ed2ff1a7584ffc2359195a2e3f9e99903b8b59fe2833559a1c1ccc429f5c363142cc4
+DIST google-auth-2.6.6.tar.gz 189789 BLAKE2B 8adf725ac8678a07c6c35f641950c5da0f269e8556074b5832a08267cbb64237dda817c576b15fbb315fd0a018e30bca1fa1f5a0d1f85aaae4ab2bd58538b191 SHA512 bac6345bf142a8dc6acde0bec43a8fd78f76277740114a0557af88748a5ec2f509757e6099f570ed037b2265717f339fe319254a826793d0b16f1a7d227a6b09
diff --git a/dev-python/google-auth/google-auth-2.6.6.ebuild b/dev-python/google-auth/google-auth-2.6.6.ebuild
new file mode 100644
index 000000000000..35f8032960a3
--- /dev/null
+++ b/dev-python/google-auth/google-auth-2.6.6.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python/
+ https://pypi.org/project/google-auth/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/cachetools-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pyu2f[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # these are compatibility tests with oauth2client
+ # disable them to unblock removal of that package
+ tests/test__oauth2client.py
+)
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}