summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-17 04:25:35 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-17 04:25:35 +0200
commit82fb6d3e17653e565dba42d9a29b347ab9f22031 (patch)
tree7a4a34d7de2821f61ae0462f79dc42ad4224fabf /dev-python/griffe
parentdev-python/griffe: Remove old (diff)
downloadgentoo-82fb6d3e17653e565dba42d9a29b347ab9f22031.tar.gz
gentoo-82fb6d3e17653e565dba42d9a29b347ab9f22031.tar.bz2
gentoo-82fb6d3e17653e565dba42d9a29b347ab9f22031.zip
dev-python/griffe: Bump to 0.46.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/griffe')
-rw-r--r--dev-python/griffe/Manifest1
-rw-r--r--dev-python/griffe/griffe-0.46.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/griffe/Manifest b/dev-python/griffe/Manifest
index 28c7e3cdbc1e..d29fb1754d81 100644
--- a/dev-python/griffe/Manifest
+++ b/dev-python/griffe/Manifest
@@ -1 +1,2 @@
DIST griffe-0.45.3.gh.tar.gz 228938 BLAKE2B fa6ea0e5aca0e7124671ccf0527f78f46be3462bac8656fb7b6ba3bf715956418477e28ba27af57c42fea4b60eabb6125e308d189c24388484c2b5e48bf2bccc SHA512 c40dac16fe7993b790be6ff1bf23aa79a84985eeeb772fae96121b625efc80d7c7d7a77aac9077997a63880b50f59ac493d1da8392ddaefd3f95fe8eda5af985
+DIST griffe-0.46.0.gh.tar.gz 232125 BLAKE2B f10b9cc020f1aa4fad8b45b17e1138cc749b410ac7566e761a47fe6d82fa236a2408182e765e05c8d7430d12ed1e6f72eff06a4a09d970ed32ec47c89518623c SHA512 467a3416353c29bc7bab8a774a3dd034b63c56655e6181d1bc11d63bfd077bb8665753837e9b8b5e909240b9a79d9e1468afba3addebb91f5b3638b732687913
diff --git a/dev-python/griffe/griffe-0.46.0.ebuild b/dev-python/griffe/griffe-0.46.0.ebuild
new file mode 100644
index 000000000000..482500b13259
--- /dev/null
+++ b/dev-python/griffe/griffe-0.46.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Signature generator for Python programs"
+HOMEPAGE="
+ https://mkdocstrings.github.io/griffe/
+ https://github.com/mkdocstrings/griffe/
+ https://pypi.org/project/griffe/
+"
+# Tests need files absent from the PyPI tarballs
+SRC_URI="
+ https://github.com/mkdocstrings/griffe/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+RDEPEND="
+ >=dev-python/colorama-0.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/jsonschema-4.17[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}
+
+EPYTEST_DESELECT=(
+ # fragile to installed packages
+ # (failed on PySide2 for me)
+ tests/test_stdlib.py::test_fuzzing_on_stdlib
+)