summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-16 07:09:22 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-16 07:30:10 +0200
commitaae7ae3649955c92dd3111aab5ef675ce77877bd (patch)
tree59f4e9bab4804d665b7254fafaf164cd149754f6 /dev-python/griffe
parentdev-python/backports-strenum: New package, v1.3.1 (diff)
downloadgentoo-aae7ae3649955c92dd3111aab5ef675ce77877bd.tar.gz
gentoo-aae7ae3649955c92dd3111aab5ef675ce77877bd.tar.bz2
gentoo-aae7ae3649955c92dd3111aab5ef675ce77877bd.zip
dev-python/griffe: Bump to 0.48.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/griffe')
-rw-r--r--dev-python/griffe/Manifest1
-rw-r--r--dev-python/griffe/griffe-0.48.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/griffe/Manifest b/dev-python/griffe/Manifest
index 08ce6f7d174f..c65ab5dc412c 100644
--- a/dev-python/griffe/Manifest
+++ b/dev-python/griffe/Manifest
@@ -1 +1,2 @@
DIST griffe-0.47.0.gh.tar.gz 233418 BLAKE2B cb31882f9ddd7210ac36eb400d182395b0da3cd37e38458f23582117aae4c83e9cd62a3dfb16067ec518a42ed6b4f6d9d77d6927be2ca462297c6420bcd25cd8 SHA512 d1d0603a81a8c859c67791ceeaf3c03a134ae221d7554b2a1133ed60a3ca85d157980b26c6930c282c50d9d46a02f26a44dffcfe0c1bd844a3f0ba58f2a1c52c
+DIST griffe-0.48.0.gh.tar.gz 370711 BLAKE2B 197da160c0e20d9669a5347fbf256db58c5a3e5e33094ddd104ae02ac9112d2daa17778ba64bc6611117a7d20af42b1b3e4101b3ec56ef8cc0dc2297d6d38a3a SHA512 3b999fbd05b206c973fe5dc7c89500f2fbfe9376529d0b5cc1714dee30f2a17985e4ed6903e638e0b96600e546747f105cab11620190185c133c53dd1df9a364
diff --git a/dev-python/griffe/griffe-0.48.0.ebuild b/dev-python/griffe/griffe-0.48.0.ebuild
new file mode 100644
index 000000000000..da6105600ada
--- /dev/null
+++ b/dev-python/griffe/griffe-0.48.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Signature generator for Python programs"
+HOMEPAGE="
+ https://mkdocstrings.github.io/griffe/
+ https://github.com/mkdocstrings/griffe/
+ https://pypi.org/project/griffe/
+"
+# Tests need files absent from the PyPI tarballs
+SRC_URI="
+ https://github.com/mkdocstrings/griffe/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/colorama-0.4[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/backports-strenum-1.3[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/jsonschema-4.17[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}
+
+EPYTEST_DESELECT=(
+ # fragile to installed packages
+ # (failed on PySide2 for me)
+ tests/test_stdlib.py::test_fuzzing_on_stdlib
+)