summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-18 20:12:29 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-18 21:43:51 +0200
commit5c469f40fba70bc6b32a8d0dffcf97f2702534d0 (patch)
tree3f200f8df8650bc16f6eae3cff2e27e1fea20a4b /dev-python/httpx
parentdev-python/zeroconf: Remove old (diff)
downloadgentoo-5c469f40fba70bc6b32a8d0dffcf97f2702534d0.tar.gz
gentoo-5c469f40fba70bc6b32a8d0dffcf97f2702534d0.tar.bz2
gentoo-5c469f40fba70bc6b32a8d0dffcf97f2702534d0.zip
dev-python/httpx: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/httpx')
-rw-r--r--dev-python/httpx/Manifest1
-rw-r--r--dev-python/httpx/files/httpx-0.18.2-big-endian.patch40
-rw-r--r--dev-python/httpx/httpx-0.18.2.ebuild63
3 files changed, 0 insertions, 104 deletions
diff --git a/dev-python/httpx/Manifest b/dev-python/httpx/Manifest
index fb87c3c7508a..eae536885318 100644
--- a/dev-python/httpx/Manifest
+++ b/dev-python/httpx/Manifest
@@ -1,2 +1 @@
-DIST httpx-0.18.2.tar.gz 1666756 BLAKE2B 3d1e25d503ae5306150c157bc83afdac9a475110d042e041b58de448a0dcfd75de3f4c15836b838dc799cd5f8b7e0d646e43bbe107ffad87d51ff016afe585cd SHA512 727974e5d5924fdd653987dd4f528d27bb2653085b01ef5efcdac39dc92ef2ed586f872c202349aa31105ad970cff914de4315c2d79338a6aa18bebb8126f392
DIST httpx-0.19.0.tar.gz 1667455 BLAKE2B b8d4cb0b6e7f643b62b507930ccf1534d73d93261cab9281ef57d6392f00da325e897d5339aebacfa07aeae8278d3a81b78d6501a1587ffeaef68cc5087bfdaa SHA512 3b327f07d62cf0430672d4f1a4f884618e588496f049522de327f5c34f7260eb21739b7f1fbd6f43a21962bc8737547f3eddbc22751546647f56c9cd7212840a
diff --git a/dev-python/httpx/files/httpx-0.18.2-big-endian.patch b/dev-python/httpx/files/httpx-0.18.2-big-endian.patch
deleted file mode 100644
index 794609d86a50..000000000000
--- a/dev-python/httpx/files/httpx-0.18.2-big-endian.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From 88a0a85ff795d8c23d5cd2cd113eeac957cc818a Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Thu, 5 Aug 2021 17:35:54 +0200
-Subject: [PATCH] Fix JSON wrong encoding tests on big endian platforms
-
-Fix test_json_without_specified_encoding_*_error tests on big endian
-platforms. The tests wrongly assume that data encoded as "utf-32-be"
-can not be decoded as "utf-32". This is true on little endian platforms
-but on big endian platforms "utf-32" is equivalent to "utf-32-be".
-To avoid the problem, explicitly decode as "utf-32-le", as this should
-trigger the expected exception independently of platform's endianness.
----
- tests/models/test_responses.py | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/tests/models/test_responses.py b/tests/models/test_responses.py
-index f1815dc..b7c2d57 100644
---- a/tests/models/test_responses.py
-+++ b/tests/models/test_responses.py
-@@ -735,7 +735,7 @@ def test_json_without_specified_encoding_decode_error():
- content = json.dumps(data).encode("utf-32-be")
- headers = {"Content-Type": "application/json"}
- # force incorrect guess from `guess_json_utf` to trigger error
-- with mock.patch("httpx._models.guess_json_utf", return_value="utf-32"):
-+ with mock.patch("httpx._models.guess_json_utf", return_value="utf-32-le"):
- response = httpx.Response(
- 200,
- content=content,
-@@ -750,7 +750,7 @@ def test_json_without_specified_encoding_value_error():
- content = json.dumps(data).encode("utf-32-be")
- headers = {"Content-Type": "application/json"}
- # force incorrect guess from `guess_json_utf` to trigger error
-- with mock.patch("httpx._models.guess_json_utf", return_value="utf-32"):
-+ with mock.patch("httpx._models.guess_json_utf", return_value="utf-32-le"):
- response = httpx.Response(200, content=content, headers=headers)
- with pytest.raises(json.decoder.JSONDecodeError):
- response.json()
---
-2.32.0
-
diff --git a/dev-python/httpx/httpx-0.18.2.ebuild b/dev-python/httpx/httpx-0.18.2.ebuild
deleted file mode 100644
index a91225037d51..000000000000
--- a/dev-python/httpx/httpx-0.18.2.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# Docs builder mkdocs not keyworded on all these arches yet
-# DOCS_BUILDER="mkdocs"
-# DOCS_DEPEND="dev-python/mkdocs-material"
-# DOCS_AUTODOC=1
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1 # docs
-
-DESCRIPTION="Fully-featured HTTP client which provides sync and async APIs"
-HOMEPAGE="https://www.python-httpx.org/"
-SRC_URI="https://github.com/encode/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ppc64 sparc x86"
-
-RDEPEND="
- dev-python/certifi[${PYTHON_USEDEP}]
- dev-python/sniffio[${PYTHON_USEDEP}]
- =dev-python/httpcore-0.13*[${PYTHON_USEDEP}]
- >=dev-python/rfc3986-1.3[${PYTHON_USEDEP}]
- <dev-python/rfc3986-2[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/brotlicffi[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/hyper-h2[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/trustme[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
- dev-python/uvicorn[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- # https://github.com/encode/httpx/pull/1781
- "${FILESDIR}"/${P}-big-endian.patch
-)
-
-python_prepare_all() {
- # trio is not currently in the tree
- sed -i '/^import trio/d' tests/concurrency.py || die
- sed -i '/pytest.param("trio", marks=pytest.mark.trio)/d' tests/conftest.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local deselect=(
- # Internet
- tests/client/test_proxies.py::test_async_proxy_close
- tests/client/test_proxies.py::test_sync_proxy_close
- )
-
- epytest ${deselect[@]/#/--deselect }
-}