summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-14 04:30:15 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-14 04:30:15 +0200
commit16a396722c728af28f44d89f042d8c1a933a016c (patch)
tree98cc4a93ff6aef5fe0c9ce197dd34b80c86f26e9 /dev-python/hypothesis
parentsys-libs/libstatgrab: conditionally build tests (diff)
downloadgentoo-16a396722c728af28f44d89f042d8c1a933a016c.tar.gz
gentoo-16a396722c728af28f44d89f042d8c1a933a016c.tar.bz2
gentoo-16a396722c728af28f44d89f042d8c1a933a016c.zip
dev-python/hypothesis: Bump to 6.75.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.75.3.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index dea5cf2fa0a1..7a54f5b6a126 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -6,3 +6,4 @@ DIST hypothesis-6.74.1.gh.tar.gz 9364092 BLAKE2B 917b98aa86319c902aff8dd7603b02e
DIST hypothesis-6.75.0.gh.tar.gz 9368603 BLAKE2B 8f98fc5b2cf24feb8ea9e417d7d75930ba7cc1ea889222ead0b1a4992ac6e7968542263d2da595598f3dd22a8c60803d10d2657c46df5784a901f382f3f8c4c7 SHA512 d4214511da6e6a628c7fe81a756d2462448d01b0c45fc7816156859ed28cc405c9b64aa2c38aa55602d6d977a6366a3423bbe8dbd00f9e5970091ccfc63dfddb
DIST hypothesis-6.75.1.gh.tar.gz 9368674 BLAKE2B 4a25c1537a5aecf0cd06850fdc8d034621a1f0a1593fb957bb671a4cd463d6ae0013b1e1b3906505f7eba7597ffda2bf698ecf594e1de6e37eaef57201a83094 SHA512 3f3b48ec93f26756c760859af489783ad2df3c93e76b9110d40fec74ffd23de07ba76f897262950f0d97b36daff7ac1f2e319f9f75b6132a9113932e3982ec5f
DIST hypothesis-6.75.2.gh.tar.gz 9369020 BLAKE2B 48ae323b529eb9fcd2b77be03b4fc5e60ac9f0b7854e61a42000f2cf0e33bd8afc173bdf25a4350f1d134f53944042b9ef13e5dbe1aa10cc5a95228629b5f34d SHA512 ef5eeb97fba78d769f97b3855665dcca842d7ceec4b83f2ae99e0f4309e00ab91e4ab603454868499b654fba29314d0bf9523ad3db3d322ffa7aedfad86b3c64
+DIST hypothesis-6.75.3.gh.tar.gz 9369491 BLAKE2B bae51e4f280a0773d4101b5b136ad994cb7eaca64a0a030bf3a9346d15a3caf7864bfc2f92bdff9eaabe83abc492b7e6cf31b19771470f6d680dbea9c83b31a4 SHA512 2e31f2f5483abf4c749dc3ef2758e51b62072e36f257777cecd71ea8f67a08987f5547bc9476dd2dbf8e9a6488fbe76d3d8ae83666bc2e80a2f26ea807cb15aa
diff --git a/dev-python/hypothesis/hypothesis-6.75.3.ebuild b/dev-python/hypothesis/hypothesis-6.75.3.ebuild
new file mode 100644
index 000000000000..6173a4ae7bc6
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.75.3.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/requests-toolbelt-0.10.1
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked,_hypothesis_pytestplugin
+
+ # NB: paths need to be relative to pytest.ini,
+ # i.e. start with hypothesis-python/
+ local EPYTEST_DESELECT=()
+ if [[ ${EPYTHON} == pypy3 ]]; then
+ EPYTEST_DESELECT+=(
+ # failing due to warnings from numpy/cython
+ hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
+ )
+ fi
+
+ epytest -o filterwarnings= -n "$(makeopts_jobs)" \
+ tests/cover tests/pytest tests/quality
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}