summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-10-23 22:25:17 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-10-23 22:32:57 +0300
commit988e74ba736927429144a384f87aa7284292f523 (patch)
tree4bef525f29104df33f18d592fff74d8e9d1bf171 /dev-python/hypothesis
parentdev-python/proto-plus: add 1.25.0 (diff)
downloadgentoo-988e74ba736927429144a384f87aa7284292f523.tar.gz
gentoo-988e74ba736927429144a384f87aa7284292f523.tar.bz2
gentoo-988e74ba736927429144a384f87aa7284292f523.zip
dev-python/hypothesis: add 6.115.4
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.115.4.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 7d6694082940..5f99903d70bc 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -3,3 +3,4 @@ DIST hypothesis-6.112.4.gh.tar.gz 9477498 BLAKE2B ef27f97b419e0bb454ef63c03ecf87
DIST hypothesis-6.114.1.gh.tar.gz 9477292 BLAKE2B 3dadb706f7d283febdc30c9e897fa5b648382edd9bba0ed0824abc2f2c1f6562f0ac77003df496d1def1e56092412c14674b5e768f9583607463f92b78770ad5 SHA512 14526a836c71cdec68a3fbd54391d4f6fe6911305fea9b349c77c59a3f352b7105531a44df05e26cd372d457ed07f7c8199967f444ede14b7d66151afe815727
DIST hypothesis-6.115.2.gh.tar.gz 9478467 BLAKE2B 6647853d1b97bdc550b884f917c29c8b1d0a163532b64df3150ccb2ab91ce8df2084260dd8dcea3125178c9c94a4603c1a66b4d8759941079438a72a6c7805df SHA512 ed141aad86d22f7a9ef9f3a84651824bcfca94dce5dfef8b579b8eb75b6e3a3db316b7b8e3c08903c2ff01609f1ce7218a9e8c738281b8b0ede6e3d7758fac8a
DIST hypothesis-6.115.3.gh.tar.gz 9478450 BLAKE2B ab29288693f05c485ddab031923ede043405b293a04c2917553e8dc01320bdf9fbf706e37e269fa0cb42b2ec8741201d87a6780d6c1deda3d581b98a63d5a47e SHA512 564d2b3cf1e847f283a73b2159086757171fc94605a315e1ccb37e515f7738a8e180211b66d233cd5bd9c47a124b35f3a8f6221212e613c5b936bb76472a924e
+DIST hypothesis-6.115.4.gh.tar.gz 9479429 BLAKE2B 2c8664f506ddc84c0350fc3a3ad7b23b49c472a18ada160adc7b1c2a35fd2de01cb7e0558bf32da211ac2ecfe2f65a2b7ab91bbacf0f150baf20f73d02cdafa9 SHA512 409dbcd04ccd46d43cef6429d89a768ae90e86b58cd35dc25315d972a9c6d4e05b40ff82a12981b02195bca0cf1acba9fab4ad3b3c6c25d5072c2696c8d347fc
diff --git a/dev-python/hypothesis/hypothesis-6.115.4.ebuild b/dev-python/hypothesis/hypothesis-6.115.4.ebuild
new file mode 100644
index 000000000000..f3d89f9d71ea
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.115.4.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( pypy3 python3_{10..13} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-8[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/requests-toolbelt-0.10.1
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,_hypothesis_pytestplugin
+ local -x HYPOTHESIS_NO_PLUGINS=1
+
+ # NB: paths need to be relative to pytest.ini,
+ # i.e. start with hypothesis-python/
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # failing due to warnings from numpy/cython
+ hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
+ )
+ ;;
+ esac
+
+ epytest -o filterwarnings= tests/cover tests/pytest tests/quality
+}
+
+src_install() {
+ local HAD_CLI=
+
+ distutils-r1_src_install
+
+ if [[ ! ${HAD_CLI} ]]; then
+ rm -r "${ED}/usr/bin" || die
+ fi
+}
+
+python_install() {
+ distutils-r1_python_install
+ if use cli && has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ HAD_CLI=1
+ else
+ rm -r "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}