summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-23 21:05:49 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-23 21:09:48 +0200
commit358602c1e85e0476e3e8b0e6c54d715201e85c21 (patch)
treebb6f80ec5f2a4d7924882b47f239e5d06c7cec71 /dev-python/identify/identify-2.4.5.ebuild
parentdev-python/starlette: add 0.18.0, enable tests (diff)
downloadgentoo-358602c1e85e0476e3e8b0e6c54d715201e85c21.tar.gz
gentoo-358602c1e85e0476e3e8b0e6c54d715201e85c21.tar.bz2
gentoo-358602c1e85e0476e3e8b0e6c54d715201e85c21.zip
dev-python/identify: add 2.4.5
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/identify/identify-2.4.5.ebuild')
-rw-r--r--dev-python/identify/identify-2.4.5.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/identify/identify-2.4.5.ebuild b/dev-python/identify/identify-2.4.5.ebuild
new file mode 100644
index 000000000000..1a5453ad9bac
--- /dev/null
+++ b/dev-python/identify/identify-2.4.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="File identification library for Python"
+HOMEPAGE="https://github.com/pre-commit/identify"
+SRC_URI="
+ https://github.com/pre-commit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="dev-python/ukkonen[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest