summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-07-30 16:29:08 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-07-30 16:29:24 -0700
commit1a3f6b58f1b9b5b1e49251d9ad989e93c3ec02d3 (patch)
treeba67edf2b9b2ecad2302ce95d7b51cd3f32e3d16 /dev-python/ijson
parentdev-python/more-itertools: ALLARCHES stable (via arm, bug #734436) (diff)
downloadgentoo-1a3f6b58f1b9b5b1e49251d9ad989e93c3ec02d3.tar.gz
gentoo-1a3f6b58f1b9b5b1e49251d9ad989e93c3ec02d3.tar.bz2
gentoo-1a3f6b58f1b9b5b1e49251d9ad989e93c3ec02d3.zip
dev-python/ijson-3.1_p0: version bump, add py3{8,9}
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/ijson')
-rw-r--r--dev-python/ijson/Manifest1
-rw-r--r--dev-python/ijson/ijson-3.1_p0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/ijson/Manifest b/dev-python/ijson/Manifest
index 9d45e2fcaecf..2aa404d8584e 100644
--- a/dev-python/ijson/Manifest
+++ b/dev-python/ijson/Manifest
@@ -1 +1,2 @@
DIST ijson-2.5.1.tar.gz 23258 BLAKE2B e41cb4d903399384a1a1d18941a2ecf36e80c762e5d4e3e854e9337f3a72cab3a61576d9d5170b11e1513bd82ca0e2158b8a88d4c30855674366fbc9172c5042 SHA512 f8d2cf0496357d3385e2744a4604cef1fd6fcd92cbd52c8803d7e831c091c18b718ad0c1dc8735c3f10df04e25fe69ef73d6935b2df6f67845493935e2ca529e
+DIST ijson-3.1_p0.tar.gz 123536 BLAKE2B d8ed0da77e219aee8ca287a2ede4eccd8e965a5778ff95485376bcfdcca07b48ae5c0e22b271fad0a489342403b11716971663158f340c97b80031bb2cc8c060 SHA512 af2db5b3c9f2cc93aa2d15462b6476a970e5c394a8f5bd9740ebbe134e8a2fa973c95057447bd02d3c4262ddf22fc7d231840d3a91b919a1411bae07d38cfd93
diff --git a/dev-python/ijson/ijson-3.1_p0.ebuild b/dev-python/ijson/ijson-3.1_p0.ebuild
new file mode 100644
index 000000000000..a8112d927075
--- /dev/null
+++ b/dev-python/ijson/ijson-3.1_p0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+MY_PV="${PV//_p/.post}"
+DESCRIPTION="Iterative JSON parser with a Pythonic interface"
+HOMEPAGE="
+ https://github.com/ICRAR/ijson
+ https://pypi.org/project/ijson/
+"
+SRC_URI="https://github.com/ICRAR/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/yajl
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest