summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-12-25 16:58:02 +0100
committerPacho Ramos <pacho@gentoo.org>2019-12-25 17:57:15 +0100
commit77a90cec9a60b87716f63018de215a5d76ed655e (patch)
tree81f507409990cccf73827459aa39b9587100dcc9 /dev-python/imageio/imageio-2.6.1.ebuild
parentapp-office/impressive: Drop old (diff)
downloadgentoo-77a90cec9a60b87716f63018de215a5d76ed655e.tar.gz
gentoo-77a90cec9a60b87716f63018de215a5d76ed655e.tar.bz2
gentoo-77a90cec9a60b87716f63018de215a5d76ed655e.zip
dev-python/imageio: Bump to 2.6.1
Also drop python2 support to not rely on numpy-python2, all reverse deps work with python3 Closes: https://bugs.gentoo.org/696644 Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'dev-python/imageio/imageio-2.6.1.ebuild')
-rw-r--r--dev-python/imageio/imageio-2.6.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/imageio/imageio-2.6.1.ebuild b/dev-python/imageio/imageio-2.6.1.ebuild
new file mode 100644
index 000000000000..244b2d640953
--- /dev/null
+++ b/dev-python/imageio/imageio-2.6.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for reading and writing image data"
+HOMEPAGE="https://imageio.github.io/"
+SRC_URI="https://github.com/imageio/imageio/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ media-libs/freeimage
+"
+DEPEND="${RDEPEND}"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"