summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-17 20:42:13 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-17 21:46:19 +0100
commitda144cb637d597a3563b37266dcd5a6caa3a2683 (patch)
treee726fa4ef78e7b9c5394adfe1e4716a1a5089516 /dev-python/imageio
parentdev-python/sentry-sdk: Bump to 1.5.0 (diff)
downloadgentoo-da144cb637d597a3563b37266dcd5a6caa3a2683.tar.gz
gentoo-da144cb637d597a3563b37266dcd5a6caa3a2683.tar.bz2
gentoo-da144cb637d597a3563b37266dcd5a6caa3a2683.zip
dev-python/imageio: Bump to 2.10.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/imageio')
-rw-r--r--dev-python/imageio/Manifest1
-rw-r--r--dev-python/imageio/imageio-2.10.5.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/imageio/Manifest b/dev-python/imageio/Manifest
index ecb32bbd8222..1bf6c23dfbc2 100644
--- a/dev-python/imageio/Manifest
+++ b/dev-python/imageio/Manifest
@@ -1 +1,2 @@
DIST imageio-2.10.4.gh.tar.gz 335495 BLAKE2B 66f8662953d7023557d4fc98b9cf2cfa00346a14286b72dd1b3abf618ee6da36da341c4a57116197e0f138424ef01050cc9176c6afcf277796aa61199e5a1530 SHA512 562bb0d7c8e627e491910f997947a4ffe967ed6dcf3d281b07145f9c8148ca0f2d9775bc89c9024ebc9bfa54f03a60aadc30a84827c050f18dbb23286ac18b96
+DIST imageio-2.10.5.gh.tar.gz 335546 BLAKE2B 1bfd418bb59f217c2108be9aedf35d1b6326d29d476ac6648041b38efa44a2220212f170cae90005e027006adfe55178dee699a1e4b37b7e948863c61432afe8 SHA512 2a058e8ce7e2ad650bea05573d249c1c06326dd1ed0f47517c3a0095a2e03fa2b90ffa5f8aae535e937b8b9fd8153ccb13267773183e45639205faddab08348a
diff --git a/dev-python/imageio/imageio-2.10.5.ebuild b/dev-python/imageio/imageio-2.10.5.ebuild
new file mode 100644
index 000000000000..cd5928118230
--- /dev/null
+++ b/dev-python/imageio/imageio-2.10.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python library for reading and writing image data"
+HOMEPAGE="https://imageio.github.io/"
+SRC_URI="
+ https://github.com/imageio/imageio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ media-libs/freeimage
+"
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Fails because of system installed freeimage
+ tests/test_core.py::test_findlib2
+)
+
+EPYTEST_IGNORE=(
+ # Needs unpackaged imageio_ffmpeg
+ tests/test_ffmpeg.py
+ tests/test_ffmpeg_info.py
+ # Needs tifffile
+ tests/test_tifffile.py
+)