summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2023-05-06 11:58:25 +0700
committerAndrey Grozin <grozin@gentoo.org>2023-05-06 11:58:25 +0700
commita142e0faff27242e7bceb4aed00b3c2b5fcde5a2 (patch)
tree7e22cd15ada7c3c9c358ab6e4417fc1fc01b53cd /dev-python/iminuit
parentdev-python/iminuit: remove old version (diff)
downloadgentoo-a142e0faff27242e7bceb4aed00b3c2b5fcde5a2.tar.gz
gentoo-a142e0faff27242e7bceb4aed00b3c2b5fcde5a2.tar.bz2
gentoo-a142e0faff27242e7bceb4aed00b3c2b5fcde5a2.zip
dev-python/iminuit: fix building with gcc-13
Closes: https://bugs.gentoo.org/895228 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'dev-python/iminuit')
-rw-r--r--dev-python/iminuit/files/iminuit-2.21.3-gcc-13.patch21
-rw-r--r--dev-python/iminuit/iminuit-2.21.3.ebuild2
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/iminuit/files/iminuit-2.21.3-gcc-13.patch b/dev-python/iminuit/files/iminuit-2.21.3-gcc-13.patch
new file mode 100644
index 000000000000..765b2f555ac4
--- /dev/null
+++ b/dev-python/iminuit/files/iminuit-2.21.3-gcc-13.patch
@@ -0,0 +1,21 @@
+From c26e9b3882d68fbef471bd67c7ea0eeb5a26c481 Mon Sep 17 00:00:00 2001
+From: andriish <andriish@users.noreply.github.com>
+Date: Thu, 4 May 2023 19:08:37 +0200
+Subject: [PATCH] Update fcn.hpp
+
+---
+ src/fcn.hpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/fcn.hpp b/src/fcn.hpp
+index 3e2ff80c..0c53e1be 100644
+--- a/src/fcn.hpp
++++ b/src/fcn.hpp
+@@ -1,6 +1,7 @@
+ #include <Minuit2/FCNGradientBase.h>
+ #include <pybind11/pytypes.h>
+ #include <vector>
++#include <cstdint>
+
+ namespace py = pybind11;
+
diff --git a/dev-python/iminuit/iminuit-2.21.3.ebuild b/dev-python/iminuit/iminuit-2.21.3.ebuild
index 5b482e3c236b..19e4fd25024d 100644
--- a/dev-python/iminuit/iminuit-2.21.3.ebuild
+++ b/dev-python/iminuit/iminuit-2.21.3.ebuild
@@ -31,6 +31,8 @@ BDEPEND="
)
"
+PATCHES=( "${FILESDIR}"/${P}-gcc-13.patch )
+
distutils_enable_tests pytest
src_test() {