summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-03 11:19:45 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-03 11:58:16 +0100
commit08972a9b766dac0f84fb86e50afbfcacde40b6fd (patch)
tree2920a87f5807061cf64828716420b8740134ba01 /dev-python/importlib_resources
parentdev-python/zipp: Use flit to build (for bootstrap) (diff)
downloadgentoo-08972a9b766dac0f84fb86e50afbfcacde40b6fd.tar.gz
gentoo-08972a9b766dac0f84fb86e50afbfcacde40b6fd.tar.bz2
gentoo-08972a9b766dac0f84fb86e50afbfcacde40b6fd.zip
dev-python/importlib_resources: Use flit to build (for bootstrap)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/importlib_resources')
-rw-r--r--dev-python/importlib_resources/importlib_resources-5.4.0-r3.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/importlib_resources/importlib_resources-5.4.0-r3.ebuild b/dev-python/importlib_resources/importlib_resources-5.4.0-r3.ebuild
new file mode 100644
index 000000000000..c63e09472b65
--- /dev/null
+++ b/dev-python/importlib_resources/importlib_resources-5.4.0-r3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+# This is a backport of Python 3.9's importlib.resources
+PYTHON_COMPAT=( pypy3 python3_8 )
+
+inherit distutils-r1
+
+DESCRIPTION="Read resources from Python packages"
+HOMEPAGE="https://github.com/python/importlib_resources"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/zipp[${PYTHON_USEDEP}]
+ ' python3_{8,9} pypy3)"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx docs dev-python/rst-linker dev-python/jaraco-packaging
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "importlib_resources"
+ version = "${PV}"
+ description = "Read resources from Python packages"
+ EOF
+}