summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-30 15:37:59 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-30 15:37:59 +0200
commit910ab7ad95611862a94b5d692928e7070c4a65fa (patch)
tree9b2a95641a79fcc0e5aa9a3f7515b4aae8422c50 /dev-python/incremental
parentxfce-extra/xfce4-screenshooter: Bump to 1.11.1 (diff)
downloadgentoo-910ab7ad95611862a94b5d692928e7070c4a65fa.tar.gz
gentoo-910ab7ad95611862a94b5d692928e7070c4a65fa.tar.bz2
gentoo-910ab7ad95611862a94b5d692928e7070c4a65fa.zip
dev-python/incremental: Bump to 24.7.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/incremental')
-rw-r--r--dev-python/incremental/Manifest1
-rw-r--r--dev-python/incremental/incremental-24.7.2.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/incremental/Manifest b/dev-python/incremental/Manifest
index f5f2a8f3da05..993efc8e378e 100644
--- a/dev-python/incremental/Manifest
+++ b/dev-python/incremental/Manifest
@@ -1 +1,2 @@
DIST incremental-22.10.0.tar.gz 18305 BLAKE2B 8e3f19e1825c608d72259729674da2dfa5005a64fb336d3c2144f20fdfd40e84ce1988cb6e00c2c86412e48f71bf2c5bd0d4f226cb49b1ff8e799065dd9fda42 SHA512 23a7572db731d1dd9871d309a02f8a29a92b7f1d897e64a2fe053575e7b486ec87e54d5ae9658eb1a82f90ba36b1b1694b58a991d841553f6cb98983725a49c3
+DIST incremental-24.7.2.tar.gz 28157 BLAKE2B c3f9e14660c1009b9083e424d451618057e17ef3799ef96368fbcd38c3738f29ee711b4114c4210f2b5970d6637c026ffa683ae3453bc4855ebcabdbe52f5500 SHA512 d738d32392ff3a3fa15b880598a74c8fe61383ab2ca167612ffdad464edda9d08fbfabfdf5c4939731c4d0489a76ba72a483fe3813351610b3618fbcc9539d82
diff --git a/dev-python/incremental/incremental-24.7.2.ebuild b/dev-python/incremental/incremental-24.7.2.ebuild
new file mode 100644
index 000000000000..2a2b7172cde5
--- /dev/null
+++ b/dev-python/incremental/incremental-24.7.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Incremental is a small library that versions your Python projects"
+HOMEPAGE="
+ https://github.com/twisted/incremental/
+ https://pypi.org/project/incremental/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/setuptools-61.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+# note: most of test deps are for examples that we can't run without
+# Internet
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/twisted[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND+="
+ >=dev-python/click-6.0[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ "${EPYTHON}" -m twisted.trial incremental ||
+ die "Tests failed on ${EPYTHON}"
+}