summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-16 21:08:16 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-16 21:15:14 +0100
commita68738ef1c70d94e83261bc338f141d85f1d4dd4 (patch)
tree64db763cf02e900bf3d588df9463c63d2ccc6e38 /dev-python/ipykernel
parentapp-shells/zsh: Stabilize 5.8.1 ppc, #833417 (diff)
downloadgentoo-a68738ef1c70d94e83261bc338f141d85f1d4dd4.tar.gz
gentoo-a68738ef1c70d94e83261bc338f141d85f1d4dd4.tar.bz2
gentoo-a68738ef1c70d94e83261bc338f141d85f1d4dd4.zip
dev-python/ipykernel: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ipykernel')
-rw-r--r--dev-python/ipykernel/Manifest1
-rw-r--r--dev-python/ipykernel/ipykernel-6.6.0.ebuild61
2 files changed, 0 insertions, 62 deletions
diff --git a/dev-python/ipykernel/Manifest b/dev-python/ipykernel/Manifest
index 9e941d823b7b..bccd4984844e 100644
--- a/dev-python/ipykernel/Manifest
+++ b/dev-python/ipykernel/Manifest
@@ -1,2 +1 @@
-DIST ipykernel-6.6.0.tar.gz 123747 BLAKE2B b1e836ac08e24baf3311e34e1323362bec94f8a59ba4cd824703f03370031226f9af41f864930c6fb59216d185e3c7e8798d6b91e88aa6ca0c214df33c6d7d37 SHA512 bf55e26a4bca0d02f4bbb87ce53a224d22a4765596f0f5d7a6d576bfa100436f676df59fa934e1d6ec66f8d802a1c7f787a9a31b906ecaa1ffd8a77fa3d96127
DIST ipykernel-6.6.1.tar.gz 123915 BLAKE2B 136a3acdea6790d4666c3f5b0d040a91be405ff35e510456d920d0d2d2fb4f4076eb8e74089d08c42f0eba50caa48da929c1a684ad414919a67748f13d6fdf78 SHA512 bfe37f3d69c9b05f9bbbdec7f2103c353433b402474507a9d17c02f224e3a80eaea010b5a8bcebfd4410fbba661feae74107a4904c0af7835c6c1aa6bd0c1159
diff --git a/dev-python/ipykernel/ipykernel-6.6.0.ebuild b/dev-python/ipykernel/ipykernel-6.6.0.ebuild
deleted file mode 100644
index b0138081d9a2..000000000000
--- a/dev-python/ipykernel/ipykernel-6.6.0.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="threads(+)"
-inherit distutils-r1
-
-DESCRIPTION="IPython Kernel for Jupyter"
-HOMEPAGE="https://github.com/ipython/ipykernel"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- $(python_gen_cond_dep '
- <dev-python/importlib_metadata-5.0.0[${PYTHON_USEDEP}]
- >=dev-python/argcomplete-1.12.3[${PYTHON_USEDEP}]
- ' python3_8 pypy3)
- >=dev-python/debugpy-1.0.0[${PYTHON_USEDEP}]
- <dev-python/debugpy-2.0[${PYTHON_USEDEP}]
- >=dev-python/ipython-7.23.1[${PYTHON_USEDEP}]
- >=dev-python/traitlets-5.1.0[${PYTHON_USEDEP}]
- <dev-python/traitlets-6.0[${PYTHON_USEDEP}]
- <dev-python/jupyter_client-8.0[${PYTHON_USEDEP}]
- >=www-servers/tornado-4.2[${PYTHON_USEDEP}]
- <www-servers/tornado-7.0[${PYTHON_USEDEP}]
- >=dev-python/matplotlib-inline-0.1.0[${PYTHON_USEDEP}]
- <dev-python/matplotlib-inline-0.2.0[${PYTHON_USEDEP}]
-"
-# RDEPEND seems specifically needed in BDEPEND, at least jupyter
-# bug #816486
-BDEPEND="
- ${RDEPEND}
- test? (
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/nose_warnings_filters[${PYTHON_USEDEP}]
- dev-python/ipyparallel[${PYTHON_USEDEP}]
- )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-6.5.0-drop-pytest-cov.patch
-)
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -i -e 's:^TIMEOUT = .*:TIMEOUT = 120:' ipykernel/tests/*.py || die
- distutils-r1_src_prepare
-}
-
-src_install() {
- distutils-r1_src_install
- # Use python3 in kernel.json configuration, bug #784764
- sed -i -e '/python3.[0-9]\+/s//python3/' \
- "${ED}"/usr/share/jupyter/kernels/python3/kernel.json || die
-}